VPLEX: Nie można włączyć portu frontonu VS2 (FE)

Podsumowanie: W tym artykule omówiono, kiedy port frontonu VS2 jest wyświetlany jako wyłączony i należy go zresetować z powrotem do włączenia.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Wpływ:
Niemożność włączenia portu frontonu VS2 w VPlexcli może prowadzić do długotrwałej utraty nadmiarowości na froncie (FE) VPLEX, a także może mieć wpływ na aktualizację sprzętu generacji (GenU) VS2 do VS6.

Problem:
VS2 z uruchomioną GeoSynchrony 6.x ma port frontonu (FE) wymieniony w VPlexcli jako mający stan "down", co oznacza, że jest wyłączony.

Próby ponownego włączenia portu FE w VPlexcli (przy użyciu polecenia "set enabled true") nie zwracają żadnych błędów, a mimo to port FE pozostaje w stanie "wyłączonym".

Przykład weryfikacji problemu:

  1. Sprawdź stan portów FE za pomocą następującego polecenia i sprawdź, które porty FE są wyłączone (wyłączone):

    W poniższych przykładowych danych wyjściowych (uwzględniamy tylko dane wyjściowe z katalogu director-1-1-B):

    • Director-1-1-B B0-FC02 jest wyłączony (wyłączony)
    • To jest port, którego dotyczy problem

    Należy również pamiętać:

    • Porty B0-FC00 i FC01 są włączone (włączone i mają łączność)
    • Port B0-FC03 jest wyświetlany jako stan "no-link" (włączony, włączony, ale brak łączności, co oznacza brak poziomu światła po stronie źródła)

    Sprawdzanie stanu portów na wszystkich silnikach i portach

    VPlexcli:/> ll /engines/*/directors/*/hardware/ports*
    or
    VPlexcli:/> ll /engines/**/ports
    
    /engines/engine-1-1/directors/director-1-1-B/hardware/ports:
    
    Name     Address             Role       Port Status
    -------  ------------------  ---------  -----------
    B-CMI00  2                   -          down
    B0-FC00  0x50001442902a0a00  front-end  up
    B0-FC01  0x50001442902a0a01  front-end  up
    B0-FC02  0x0000000000000000  front-end  down <<<< port with issue
    B0-FC03  0x50001442902a0a03  front-end  no-link
    B1-FC00  0x50001442902a0a10  back-end   up
  2. Spróbuj włączyć port "down" za pomocą polecenia VPlexcli: set enabled true

    1. Po pierwsze, cd w kontekście danego portu FE,
      przykład:
      VPlexcli:/> cd /engines/engine-1-1/directors/director-1-1-B/hardware/ports/B0-FC02
    2. Następnie wydaj polecenie: set enabled true
      Przykład:
      VPlexcli:/engines/engine-1-1/directors/director-1-1-B/hardware/ports/B0-FC02> set enabled true
      VPlexcli:/engines/engine-1-1/directors/director-1-1-B/hardware/ports/B0-FC02>
      Uwaga: Żaden błąd nie zostanie zwrócony, po uruchomieniu polecenia monit zostanie zwrócony, jak pokazano powyżej.
    3. Z poziomu kontekstu "B0-FC02" uruchom polecenie "cd ..", aby zmienić poziom kontekstu na "ports" modułu director, a następnie uruchom polecenie "ll", aby ponownie sprawdzić stan portu. Nadal jest wyświetlany ze stanem "wyłączony":
      Przykład:
      VPlexcli:/engines/engine-1-1/directors/director-1-1-B/hardware/ports/B0-FC02> cd ..
      VPlexcli:/engines/engine-1-1/directors/director-1-1-B/hardware/ports> ll
      Name     Address             Role       Port Status
      -------  ------------------  ---------  -----------
      B-CMI00  2                   -          down
      B0-FC00  0x50001442902a0a00  front-end  up
      B0-FC01  0x50001442902a0a01  front-end  up
      B0-FC02  0x0000000000000000  front-end  down <<< still shows as down like before
      B0-FC03  0x50001442902a0a03  front-end  no-link

Generacja VS2 do VS6 może również ulec awarii, jeśli VS2 ma port FE w stanie "wyłączonym" przed GenU.

Podczas GenU stan/ustawienia VS2 (w tym porty FE) są przenoszone do VS6, a następnie podczas części fazy transferu we/wy GenU, gdy moduł director VS6 jest wywoływany, porty FE są włączane. Jeśli jeden lub więcej portów VS2 FE jest w stanie "wyłączonym" (wyłączonym) przed GenU, a zwłaszcza jeśli tych portów nie można włączyć w VPlexcli, może to doprowadzić do niepowodzenia fazy transferu we/wy. Ponieważ krok włączania portów FE w module Director VS6 po cichu kończy się niepowodzeniem, a następnie kolejny krok czeka, aż wszystkie porty FE będą miały "włączone"; stan (w katalogu VS6) kończy się niepowodzeniem z powodu błędu przekroczenia limitu czasu.

Przykład błędu zwróconego podczas fazy transferu we/wy GenU:

Continuing I/O transfer with connectivity issues could cause data unavailability and system instability. Connectivity issues must be fixed before proceeding. Would you like to re-check connectivity? (Retry/Abort): retry
Transferring director-2-1-A to VS6: .....................ERROR <<<<<
Failed to complete director transfer to VS6: hardware-upgrade Evaluation of
 <<hardware-upgrade transfer-io --vs6 --director transfer-io: director-2-1-A>> failed. <<<<<<
cause: Command execution failed. cause: *Evaluation of <<wait -c
[/engines/engine-2-1/directors/director-2-1-A/hardware/ports/A0-FC00,
 /engines/engine-2-1/directors/director-2-1-A/hardware/ports/A0-FC01,
 /engines/engine-2-1/directors/director-2-1-A/hardware/ports/A0-FC02,
 /engines/engine-2-1/directors/director-2-1-A/hardware/ports/A0-FC03] -a enabled -v*
 True -t 240>> failed. cause: Command execution failed. cause: Timed out after 240 seconds

 

Przyczyna

Wewnętrzny komponent VPLEX powiązany z portem FE jest wyłączony. Główna przyczyna wyłączenia tego stanu nie jest jeszcze znana.

 

Rozwiązanie

W przypadku wystąpienia tego problemu skontaktuj się z działem obsługi klienta Dell VPLEX w celu wdrożenia obejścia problemu i włączenia portu FE. Kontaktując się z działem obsługi klienta firmy Dell, wspomnij o tym artykule.

Trwałe rozwiązanie:
Inżynierowie Dell VPLEX obecnie badają ten problem. Po udostępnieniu poprawki ten artykuł zostanie zaktualizowany.

 

Produkty, których dotyczy problem

VPLEX Series

Produkty

VPLEX Series, VPLEX VS2
Właściwości artykułu
Numer artykułu: 000168183
Typ artykułu: Solution
Ostatnia modyfikacja: 05 maj 2026
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.