NetWorker: funkcja FLR vProxy kończy się niepowodzeniem z powodu błędu "Nie udało się zalogować do usługi Data Domain", resetowania połączenia lub przekroczenia terminu kontekstu

Podsumowanie: Funkcja FLR vProxy kończy się niepowodzeniem z błędem "Failed to log in to Data Domain service". Dzienniki sesji montowania wskazują na awarię połączenia sieciowego TCP. Połączenie TCP zostało zresetowane lub przekroczony termin ostateczny kontekstu. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

NetWorker VMware Protection (NVP) FLR kończy się niepowodzeniem, zgłaszając błąd "Nie udało się zalogować do usługi Data Domain"

Zasoby systemów NetWorker Data Domain są skonfigurowane z odpowiednim użytkownikiem na poziomie administratora dla Data Domain:

Użytkownik Data Domain Management

UWAGA: Użytkownik zarządzania musi być użytkownikiem na poziomie administratora domeny danych, na przykład: sysadmin. Hasło musi być poprawne. Sprawdź, czy możesz zalogować się do interfejsu sieciowego zarządzania Data Domain jako sysadmin. Jeśli zalogowano się pomyślnie, zaktualizuj pole "hasło zarządzania" dla Data Domain w NetWorker, aby upewnić się, że ustawiono prawidłowe hasło.

 

W dziennikach sesji vProxy FLR mount lub Instant Recover jest wyświetlany komunikat 'Failed to login to DataDomain service' zgłaszając problem z połączeniem sieciowym.

Zapisane dzienniki sesji odzyskiwania znajdują się na serwerze NetWorker w sekcji:

  • Linux: /nsr/logs/recover
  • Windows (domyślnie): C:\Program Files\EMC NetWorker\nsr\logs\recover

Dzienniki instalacji FLR znajdują się na serwerze NetWorker w sekcji:

  • Linux: /nsr/logs/adhoc/nsrvproxy_flr
  • Windows (domyślnie): C:\Program Files\EMC NetWorker\nsr\logs\adhoc\nsrvproxy_flr

Dzienniki sesji odzyskiwania vProxy znajdują się w sekcji:

  • /opt/emc/vproxy/runtime/logs/vflrd
  • /opt/emc/vproxy/runtime/logs/recycle/vflrd

Przykładowe komunikaty:

Unmounting after mount failure: Unable to create NFS export at '[DD_FQDN]:/data/col1/[NW_MTREE]/FLR-[VM_NAME]-[SSID_FOLDER]': Unable to login while creating NFS export at '[DD_FQDN]:/data/col1/[NW_MTREE]/FLR-[VM_NAME]-[SSID_FOLDER]': Failed to login to DataDomain service at 'https://[DD_NAME]:3009/rest/v1.0/auth': Post https://[DD_FQDN]:3009/rest/v1.0/auth: read tcp []->[]:3009: read: connection reset by peer
Failed to login to DataDomain service at 'https://[DD_FQDN]:3009/rest/v1.0/auth': Post "https://[DD_FQDN]:3009/rest/v1.0/auth": context deadline exceeded (Client.Timeout exceeded while awaiting headers)
Unmounting after mount failure: Unable to create NFS export at '[DD_FQDN]:/data/col1/[NW_MTREE]/FLR-[VM_NAME]-[SSID_FOLDER]': Unable to login while creating NFS export at '[DD_FQDN]:/data/col1/[NW_MTREE]/FLR-[VM_NAME]-[SSID_FOLDER]': Failed to login to DataDomain service at 'https://[DD_FQDN]:3009/rest/v1.0/auth': Post "https://[DD_FQDN]:3009/rest/v1.0/auth": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

Tworzenie kopii zapasowych maszyny wirtualnej w Data Domain powiodło się.
Przywracanie obrazu lub dysku z systemu Data Domain zakończyło się pomyślnie.

Przyczyna

Składnik sieci lub zapora uniemożliwia nawiązanie połączenia, co powoduje wyświetlenie komunikatu o błędzie "resetowanie połączenia przez element równorzędny" lub przekroczenia limitu czasu.

FLR i Instant Recover używają innych protokołów niż kopia zapasowa lub przywracanie obrazu. Te błędy połączenia można zaobserwować podczas wykonywania FLR lub Instant Recovery, podczas gdy wszystkie inne operacje ochrony obrazu kończą się powodzeniem.

Rozwiązanie

Do zidentyfikowania miejsca występowania problemu można użyć następujących danych wyjściowych:

  1. Z poziomu vProxy curl polecenia sprawdzające, czy można połączyć się z portami 22, 2049, 2052 i 3009 na DD:
curl -v DD_HOSTNAME:PORT

 

  1. Z poziomu vProxy sprawdź, czy vProxy może nawiązać połączenie SSL z DD:
curl -kv https://DD_HOSTNAME:3009/rest/v1.0/trust
UWAGA: Oczekuje się, że dane wyjściowe tego polecenia zwrócą certyfikat SSL z podpisem własnym używany do łączenia się z Data Domain. Jeśli wersja vProxy jest znacznie nowsza niż system operacyjny DD, może wystąpić błąd uzgadniania TLS: NetWorker: niepowodzenie uzgadniania TLS funkcji FLR vProxy z błędem "Nie udało się zalogować do usługi Data Domain".

 

  1. Z poziomu hosta hosta ESXi vProxy używanego do FLR (widocznego w VMware) sprawdź, czy host ESXi może osiągnąć porty 22, 2049, 2052, 3009 na DD.

nc -zv DD_HOSTNAME PORT

 
UWAGA: Jeśli podczas powyższych kroków zostaną zaobserwowane jakiekolwiek problemy z połączeniami, takie jak zablokowane porty lub przekroczenie limitu czasu, skontaktuj się z administratorami sieci i VMware. Jeśli nie zaobserwowano żadnych bezpośrednich problemów z połączeniem, przejdź do kolejnych kroków, aby dokładniej sprawdzić ruch.
    1. W sesji SSH na serwerze vProxy, użyj tcpdump , aby rozpocząć przechwytywanie pakietów między vProxy i DD.

    sudo tcpdump -i any -s 0 -C 500 -w /tmp/$(hostname)_$(date -I).pcap 'host VPROXY_IP-ADDRESS or host DD_IP-ADDRESS'

    • -i określa interfejs, możesz użyć dowolnego lub określić nazwę interfejsu sieciowego systemu, na przykład eth0.
    • -s 0 Określa długość przyciągania 65535 (przechwytywana jest cała klatka).
    • -C 500 wskazuje rozmiar pliku 500 000 000 bajtów.
    • -w wskazuje lokalizację pliku wyjściowego. Wyświetlany plik wyjściowy jest generowany automatycznie z nazwą hosta systemowego i RRRR-MM-DD, że został uruchomiony. 
    • VPROXY_IP-ADDRESS określ adres IP, którego vProxy używa do komunikacji z Data Domain.
    • DD_IP-ADDRESS określ docelowy adres IP w Data Domain, z którym komunikuje się vProxy.
      • Określenie źródłowego i docelowego adresu IP ogranicza przechwytywanie pakietów, aby pokazać tylko ruch między dwoma określonymi adresami. 
    1. Z poziomu NMC lub NWUI zainicjuj montaż FLR. W przypadku zaobserwowania problemu zatrzymaj tcpdump (CTRL+C) i przejrzyj sygnaturę czasową .pcap plik z pliku /tmp w przypadku problemów z połączeniem.
    UWAGA: A .pcap plik może być analizowany w programie Wireshark. WiresharkKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies. to narzędzie innej firmy służące do analizowania przechwytywania pakietów. Skontaktuj się z administratorem sieci, aby uzyskać pomoc dotyczącą przechwytywania pakietów. 

    Dodatkowe informacje

    Można również zaobserwować "Failed to login to DataDomain service', jeśli konto zarządzania DD jest zablokowane lub jeśli poświadczenia w NetWorker są puste lub nieprawidłowe:

    Usługa REST musi być włączona w Data Domain, zobacz:

    Aby uzyskać dodatkowe informacje o portach i instrukcje rozwiązywania problemów z połączeniem sieciowym, zobacz:

    Produkty, których dotyczy problem

    NetWorker

    Produkty

    NetWorker Family
    Właściwości artykułu
    Numer artykułu: 000173057
    Typ artykułu: Solution
    Ostatnia modyfikacja: 04 lut 2026
    Wersja:  8
    Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
    Usługi pomocy technicznej
    Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.