AppSync: Jeśli uruchomienie bazy danych Oracle na serwerze z systemem Red Hat Linux trwa ponad 5 minut, AppSync może przekroczyć limit czasu i zakończyć się niepowodzeniem odzyskiwania.
Podsumowanie: Jeśli podczas operacji instalacji i odzyskiwania bazy danych Oracle na serwerze z systemem Red Hat Linux uruchomienie AppSync trwa ponad 5 minut, może to spowodować przekroczenie limitu czasu podczas oczekiwania. Kolejne zadania odinstalowania zakończą się niepowodzeniem z tego samego powodu. ...
Ten artykuł dotyczy
Ten artykuł nie dotyczy
Ten artykuł nie jest powiązany z żadnym konkretnym produktem.
Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.
Objawy
Następujący błąd może być widoczny podczas wykonywania operacji instalacji i odzyskiwania bazy danych Oracle na serwerze z systemem Red Hat Linux jako część planu serwisowego lub jako operacja na żądanie.
Wystąpił błąd podczas uruchamiania openDatabase na hoście <HOST MONTOWANIA>. Aby uzyskać więcej informacji, należy zapoznać się z dziennikiem <UUID>_openDatabase.log na hoście agenta.
System plików pozostanie zainstalowany, a baza danych Oracle może zostać uruchomiona. Kolejne odinstalowania zakończą się niepowodzeniem z powodu błędu:
Wystąpił błąd podczas uruchamiania shutdownDb na hoście <HOST MONTOWANIA>. Aby uzyskać więcej informacji, należy zapoznać się z dziennikiem <UUID>_shutdownDb.log na hoście agenta.
Przyczyna
Ten problem jest spowodowany przerwaniem sesji SSHD miedzy serwerem AppSync i agentem przez hosta, na którym zainstalowany jest agent AppSync. Można to potwierdzić, sprawdzając następujące wpisy w pliku /etc/ssh/sshd_config.
Te dwa ustawienia sterują sesjami SSHD i zakończą wszelkie sesje, które są nieaktywne dłużej niż określony czas. Jeśli ich nie ma lub są skomentowane, to używana jest wartość domyślna (widoczna powyżej). ClientAliveInterval to czas w minutach zanim sesja zostanie zakończona lub zostanie wysłany token keepalive. ClientAliveCountMax to liczba tokenów keepalive, które zostaną wysłane przed zakończeniem sesji.
Aby dowiedzieć się, jak długo sesja SSHD będzie otwarta, jeśli nie ma aktywności, pomnóż obie wartości razem. Domyślnie oznacza to, że sesja zakończy się po upływie 5 minut (5 × 0).
ClientAliveInterval 5
ClientAliveCountMax 0
ClientAliveCountMax 0
Te dwa ustawienia sterują sesjami SSHD i zakończą wszelkie sesje, które są nieaktywne dłużej niż określony czas. Jeśli ich nie ma lub są skomentowane, to używana jest wartość domyślna (widoczna powyżej). ClientAliveInterval to czas w minutach zanim sesja zostanie zakończona lub zostanie wysłany token keepalive. ClientAliveCountMax to liczba tokenów keepalive, które zostaną wysłane przed zakończeniem sesji.
Aby dowiedzieć się, jak długo sesja SSHD będzie otwarta, jeśli nie ma aktywności, pomnóż obie wartości razem. Domyślnie oznacza to, że sesja zakończy się po upływie 5 minut (5 × 0).
Rozwiązanie
Aby to naprawić, należy przejrzeć dziennik <UUID>_openDatabase.log znajdujący się w katalogu dzienników wtyczki AppSync hostów odzyskiwania (domyślnie /opt/emc/appsync/logs). To pokaże, jak długo baza danych była uruchamiana. Dla bazy danych, której uruchomienie trwało około 20 minut, limit czasu SSHD powinien być ustawiony na 25 lub 30 minut. Umożliwi to narzut przyszłych zmian.
Dokonaj edycji pliku /etc/ssh/sshd_config z poniższymi zmianami, aby sesja pozostała otwarta przez 30 minut:
Po dokonaniu tej edycji należy ponownie uruchomić SSHD, aby zmiany zostały wprowadzone. Można uruchomić ponownie hosta lub wykonać następujące polecenie, aby ponownie uruchomić SSHD:
Dokonaj edycji pliku /etc/ssh/sshd_config z poniższymi zmianami, aby sesja pozostała otwarta przez 30 minut:
ClientAliveInterval 5
ClientAliveCountMax 6
ClientAliveCountMax 6
Po dokonaniu tej edycji należy ponownie uruchomić SSHD, aby zmiany zostały wprowadzone. Można uruchomić ponownie hosta lub wykonać następujące polecenie, aby ponownie uruchomić SSHD:
/etc/init.d/sshd restart
Produkty
Red Hat Enterprise Linux Version 6, Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 8Właściwości artykułu
Numer artykułu: 000185055
Typ artykułu: Solution
Ostatnia modyfikacja: 12 gru 2022
Wersja: 5
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.