AppSync : AppSync n’envoie pas de commande d’API REST pour oublier l’unité logique, ce qui entraîne des erreurs dans VPLEX

Podsumowanie: Au cours de l’opération de démontage AppSync, AppSync est censé envoyer une commande d’API REST pour oublier l’unité logique dans VPLEX. Mais il n’envoie pas la même commande, raison pour laquelle les unités logiques sont inaccessibles dans VPLEX et des erreurs sont affichées dans l’interface utilisateur VPLEX. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Le client voit les erreurs ci-dessous dans l’interface utilisateur VPLEX :

ForgetUnReachableLun.jpg

Dans le même temps, le plan de service AppSync et la phase de démontage sont réussies. 
Dans le journal du serveur, AppSync n’envoie pas l’API ci-dessous pour oublier l’unité logique dans VPLEX

<Date & Time> executeRequest: executing POST: POST https://<VPLX Server IP/Name>/vplex/logical-unit+forget HTTP/1.1
<Date & Time> executeRequest: Response Status Line: HTTP/1.1 200 OK
    
Mais AppSync affirme avoir terminé l’opération pour oublier toutes les unités logiques de VPLEX

<Date & Time> INFO [EJB default - 5] [com.emc.archway.service.eventservice.EventServiceBean] [AppSync Server Name] [] 5e534c36-54c1-4874-921a-5a9fbb98eeed->>> EVENT [VPLEX_000052]: Completed operation on the VPLEX cluster <VPLEX ID> to forget all logical units which were unmounted.(METADATA: TYPE-INFO, TIME-2021-06-03 04:06:42.450+0200NATIVETIME-<Date & Time> .450+0200, HOST-EMCAppSync, PHASE-Create 1st gen copy, THREAD=EJB default - 5, USER-null, CATEGORY-GENERIC, SESSIONID-null)

 

Przyczyna

Dans AppSync 4.2, en raison d’un bug de code, AppSync n’envoie pas l’API REST pour oublier toutes les unités logiques s’il n’obtient pas les détails du volume de stockage appropriés à partir de l’appel get-storage-volume-info dont dépend la demande d’unité logique d’oubli.  
 

Rozwiązanie

Un correctif existe pour résoudre ce problème. Contactez le support technique en vous référant à cet article de la base de connaissances afin d’obtenir le correctif.

Produkty

AppSync
Właściwości artykułu
Numer artykułu: 000189275
Typ artykułu: Solution
Ostatnia modyfikacja: 03 lis 2021
Wersja:  3
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.