AppSync : échec du plan de service SQL lors de la phase de découverte des applications avec l’erreur : Unable to connect to database.

Podsumowanie: Le plan de service SQL a échoué lors de la phase de découverte des applications avec l’erreur : Unable to connect to database Unable to connect to database. Cela peut se produire si la base de données SQL n’est pas à l’état en ligne ou si le pilote ODBC n’est pas correctement installé. Pour plus d’informations, consultez le journal du plug-in hôte AppSync. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Le plan de service a échoué lors de la phase de découverte des applications avec l’erreur : Unable to connect to database Unable to connect to database <Db name>. Cela peut se produire si la base de données SQL n’est pas à l’état en ligne ou si le pilote ODBC n’est pas correctement installé.
 Pour plus d’informations, consultez le journal du plug-in hôte AppSync.
 
Journaux d’évènements AppSync :
 
Application discovery,7d2c438e-6ea7-4bb9-b515-0ce2594f9315,SQL_000141,<AppSync Server>,Unable to connect to database <Db name>. Cela peut se produire si la base de données SQL n’est pas à l’état en ligne ou si le pilote ODBC n’est pas correctement installé. Pour plus d’informations, consultez le journal du plug-in hôte AppSync.
 
Journaux du serveur AppSync :
 
07-02-2021 06:00:05.840 INFO [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [SQL_000141]: Unable to connect to database hostname.master. Cela peut se produire si la base de données SQL n’est pas à l’état en ligne ou si le pilote ODBC n’est pas correctement installé. Check the AppSync host plug-in log for more details.(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:05.840-0600NATIVETIME-2021-07-02 06:00:05.643-0600, HOST-hostname.a.b.corporate. com, PHASE-Application discovery, THREAD=17152, USER-null, CATEGORY-GENERIC, SESSIONID-null)
07-02-2021 06:00:05.841 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [org.jboss.as.ejb3.invocation] [ASServer] [] WFLYEJB0034: EJB Invocation failed on component SqlServiceBean for method public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice.SqlServiceBean.discoverDatabases(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.host.AgentHost,com.emc.archway.objectmodel.host.sql.SqlServerInstances) throws java.net.UnknownHostException,com.emc.archway.service.eventservice.exceptions.HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException
07-02-2021 06:00:06.032 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: RuntimeException
07-02-2021 06:00:06.035 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: EJBException, Message: java.lang.RuntimeException
07-02-2021 06:00:07.272 INFO [Thread-28456 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [MILE_000005]: Application discovery phase for hostname:Utility completed with errors(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:07.272-0600NATIVETIME-2021-07-02 06:00:07.272-0600, HOST-ASServer, PHASE-Application discovery, THREAD=Thread-28456 (HornetQ-client-global-threads-320952484), USER-null, CATEGORY-MILESTONE, SESSIONID-null)

Przyczyna

La protection de la base de données SQL échouait, car l’utilisateur fourni à AppSync pour SQL ne disposait pas des privilèges requis.
 


Rozwiązanie


La réinitialisation de l’authentification Windows des bases de données auprès de l’utilisateur approprié permet de résoudre le problème.

Étapes de réinitialisation de l’authentification :
 
1. Sur la console AppSync, sélectionnez Copy Management.
2. Dans la liste déroulante Copies, sélectionnez Copies.
3. Dans la liste déroulante Select Application, sélectionnez Microsoft SQL Server pour afficher la page de l’instance.
4. Sélectionnez une base de données, puis cliquez sur CONNECTION SETTINGS.
La boîte de dialogue Server Connection settings s’affiche.
5. Dans le champ Authentification, sélectionnez l’une des conditions suivantes par site :
● Windows Authentication
● SQL Server Authentication
6. Spécifiez des valeurs pour les champs suivants :
● Username
● Password
7. Cliquez sur OK

Produkty, których dotyczy problem

AppSync

Produkty

Data Protection, Data Backup & Protection Software
Właściwości artykułu
Numer artykułu: 000189823
Typ artykułu: Solution
Ostatnia modyfikacja: 11 maj 2026
Wersja:  7
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.