AppSync: 애플리케이션 검색 단계 중에 다음 오류와 함께 SQL 서비스 계획이 실패했습니다. Unable to connect to database

Podsumowanie: 애플리케이션 검색 단계 중에 다음 오류와 함께 SQL 서비스 계획이 실패했습니다. Unable to connect to database Unable to connect to database. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

애플리케이션 검색 단계 중에 다음 오류와 함께 서비스 계획이 실패했습니다. Unable to connect to database Unable to connect to database <Db name>. This can happen if either SQL database is not in online state or ODBC driver is not properly installed.
 Check the AppSync host plug-in log for more details.
 
AppSync 이벤트 로그:
 
Application discovery,7d2c438e-6ea7-4bb9-b515-0ce2594f9315,SQL_000141,<AppSync Server>,Unable to connect to database <Db name>. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details.
 
AppSync Server 로그:
 
07-02-2021 06:00:05.840 INFO [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [SQL_000141]: Unable to connect to database hostname.master. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details.(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:05.840-0600NATIVETIME-2021-07-02 06:00:05.643-0600, HOST-hostname.a.b.corporate. com, PHASE-Application discovery, THREAD=17152, USER-null, CATEGORY-GENERIC, SESSIONID-null)
07-02-2021 06:00:05.841 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [org.jboss.as.ejb3.invocation] [ASServer] [] WFLYEJB0034: EJB Invocation failed on component SqlServiceBean for method public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice.SqlServiceBean.discoverDatabases(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.host.AgentHost,com.emc.archway.objectmodel.host.sql.SqlServerInstances) throws java.net.UnknownHostException,com.emc.archway.service.eventservice.exceptions.HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException
07-02-2021 06:00:06.032 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: RuntimeException
07-02-2021 06:00:06.035 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: EJBException, Message: java.lang.RuntimeException
07-02-2021 06:00:07.272 INFO [Thread-28456 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [MILE_000005]: Application discovery phase for hostname:Utility completed with errors(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:07.272-0600NATIVETIME-2021-07-02 06:00:07.272-0600, HOST-ASServer, PHASE-Application discovery, THREAD=Thread-28456 (HornetQ-client-global-threads-320952484), USER-null, CATEGORY-MILESTONE, SESSIONID-null)

Przyczyna

AppSync for SQL에 제공된 사용자에게 필요한 권한이 없기 때문에 SQL DB 보호가 실패합니다.
 


Rozwiązanie


DB의 Windows 인증을 적절한 사용자 권한으로 재설정하면 문제가 해결됩니다.

인증 재설정 단계:
 
1. AppSync 콘솔에서 Copy Management를 선택합니다.
2. Copies 드롭다운에서 Copies를 선택합니다.
3. Select Application 드롭다운에서 Microsoft SQL Server를 선택하여 인스턴스 페이지를 표시합니다.
4. 데이터베이스를 선택하고 CONNECTION SETTINGS를 클릭합니다.
SQL Server Connection 설정 대화 상자가 나타납니다.
5. Authentication 필드에서 사이트 요구 사항에 따라 다음 중 하나를 선택합니다.
● Windows 인증
● SQL Server 인증
6. 다음 필드의 값을 지정합니다.
● Username
● Password
7. 확인을 클릭합니다.

Produkty, których dotyczy problem

AppSync

Produkty

Data Protection, Data Backup & Protection Software
Właściwości artykułu
Numer artykułu: 000189823
Typ artykułu: Solution
Ostatnia modyfikacja: 11 maj 2026
Wersja:  7
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.