PowerEdge: Alert o wygaśnięciu hasła użytkownika AD w kliencie vSphere H5

Podsumowanie: vCenter włącza usługę Active Directory (AD), a logowanie przez użytkowników Active Directory powoduje wyświetlenie powiadomienia "Hasło wygaśnie za X dni", klient musi je wyeliminować.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

  1. Logowanie do vCenter przez użytkowników Active Directory ma powiadomienie "Hasło wygasa za 26 dni"
    Klient vSphere
  2. W przypadku zamiany na login użytkownika administratora vCenter nie wyświetlaj powiadomienia "Hasło wygasa za X dni"
    Klient vSphere

Przyczyna

Powiadomienie o wygaśnięciu hasła usługi Active Directory jest niezależne od powiadomienia o wygaśnięciu hasła logowania jednokrotnego serwera vCenter Server. Domyślne powiadomienie o wygaśnięciu hasła dla użytkownika usługi Active Directory ma 30 dni, ale czas wygaśnięcia hasła zależy od systemu Active Directory. Klient vSphere Client steruje powiadomieniem o wygaśnięciu. Możesz zmienić domyślne powiadomienie o wygaśnięciu, aby spełniało standardy zabezpieczeń w Twojej firmie.

Rozwiązanie

  1. Logowanie SSH do interfejsu wiersza poleceń vCenter Server
    Putty 
  2. Zmień katalog na lokalizację klienta vSphere Client webclient.properties file
    Uwaga: 5 Client - /etc/vmware/vsphere-ui/webclient.properties
    cd /etc/vmware/vsphere-ui
    Putty 
    Putty 
  3. Otwórz plik webclient.properties za pomocą edytora tekstu
    vim  /etc/vmware/vsphere-ui/webclient.properties
    Putty 
  4. Edytuj następującą zmienną,  sso.pending.password.expiration.notification.days = 30 -a 5
    Putty 
  5. Uruchom ponownie klienta vSphere Client.
    service-control --stop vsphere-ui
    service-control --start vsphere-ui
    Putty 
  6. vCenter zalogowane ponownie przez użytkowników Active Directory, powiadomienie "Hasło wygasa za 26 dni" zniknęło
    VMware vSphere
    Zapoznaj się z dokumentem i artykułem bazy wiedzy:
    Dokumentacja
    produktu VMware vSphere 7.0https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.authentication.doc/GUID-861C3140-A9AE-42A5-83EF-BC2CCEA9E4C7.htmlKliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.
    Zmiana powiadomienia "Hasło wygasa za X dni" dla użytkowników Active Directory w kliencie
    vSphere Web/H5https://williamlam.com/2017/11/changing-password-will-expire-in-x-days-notification-for-active-directory-users-in-vsphere-web-h5-client.html Kliknięcie tego hiperłącza powoduje wyświetlenie strony spoza witryny Dell Technologies.

Produkty, których dotyczy problem

Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M7701, PowerEdge M7725 , PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R250, PowerEdge R350, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, VMware Carbon Black, VMware ESXi 8.x, VMware ESXi 9.x, VMware OEM Products with ProSupport, VMware VSAN ...
Właściwości artykułu
Numer artykułu: 000192597
Typ artykułu: Solution
Ostatnia modyfikacja: 16 lut 2026
Wersja:  3
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.