Narzędzie OMSA: 10.1 Nie odpowiada na zapytania WMI i SNMP DELL_CM

Podsumowanie: Oprogramowanie Dell OpenManage Server Administrator w wersji 10.1.0 i nowszych nie odpowiada już na bezpośrednie zapytania WMI lub SNMP z sześciu DELL_CMxxxx klas różnych elementów inwentaryzacji systemu. Jest to spowodowane decyzją inżyniera firmy Dell o usunięciu podstawowego modułu Inventory Collector (IC) ze względu na ograniczenia związane z bezpieczeństwem i rozmiarem pakietu instalacyjnego. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Odpytując następujące klasy z Dell OpenManage Server Administrator (OMSA) 10.1.0 i nowsze, zwraca teraz wyniki zerowe:

  • DELL_CMApplication
  • DELL_CMDevice
  • DELL_CMDeviceApplication
  • DELL_CMInventory
  • DELL_CMOS
  • DELL_CMProductInfo

Klasy te zawierają różne informacje o zasobach, takie jak bieżące wersje oprogramowania wewnętrznego i sterowników składników systemu, podstawowe informacje o systemie operacyjnym itd.

Przyczyna

Inżynierowie firmy Dell zdecydowali się już nie łączyć modułu Inventory Collector (IC) w pakiet ze względu na nieaktualne wersje pozostające w oprogramowaniu OMSA, duże ograniczenia dotyczące rozmiaru instalacji i przepustowości oraz problemy z bezpieczeństwem. We wcześniejszych latach IC obsługiwało głównie aplikacje Dell IT Assistant i Dell OpenManage Essentials. OMSA 9.5 to ostatnia wersja pakietu IC. Oba te produkty zostały wycofane i zastąpione przez Dell OpenManage Enterprise, które opiera się na kontrolerze iDRAC zamiast OMSA.

Rozwiązanie

Jeśli dane inwentaryzacji z tych klas są nadal wymagane do bezpośredniego programowania WMI lub SNMP za pomocą narzędzia OMSA, ręcznie pobierz i zainstaluj moduł IC w następujących ścieżkach. Następnie należy włączyć i ponownie uruchomić usługę współdzieloną OMSA:

Windows:

  1. Utwórz foldery "cm" i "invcol" w ciągu C:\Program Files\Dell\SysMgt\
  2. Pobierz IC dla systemu Windows pod adresem: https://downloads.dell.com/FOLDER07847532M/1/invcol_8YPK7_WIN64_21_12_200_1196_A00.exe
  3. Zmień nazwę pobierania na invcol.exe i przenieś do C:\Program Files\Dell\SysMgt\cm\invcol\
  4. Uruchom ponownie usługi współdzielone DSM SA i poczekaj do 10 minut, aż IC zakończy inwentarz początkowy.

Linux:

  1. Pobierz IC dla systemu Linux pod adresem: https://downloads.dell.com/FOLDER07847525M/1/invcol_8YPK7_LN64_21_12_200_1196_A00.BIN
  2. Zmień nazwę na invcol i przejdź do /opt/dell/srvadmin/sbin/lx64/.
  3. W wierszu poleceń powłoki uruchom polecenie: 
srvadmin-services restart

Produkty, których dotyczy problem

OpenManage Server Administrator, Dell OpenManage Server Administrator Version 10.1.0.0, OEMR R240, OEMR R250, OEMR XE R250, OEMR R260, OEMR XE R260, OEMR R340, OEMR R350, OEMR XE R350, OEMR R360, OEMR XE R360, OEMR R440, PowerEdge XR2, OEMR R450 , OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T140, OEMR T150, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, OEMR XR11, OEMR XR12, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7100, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9640, PowerEdge XE9680, PowerEdge XE9680L, PowerEdge XR11, PowerEdge XR12 ...
Właściwości artykułu
Numer artykułu: 000193542
Typ artykułu: Solution
Ostatnia modyfikacja: 29 kwi 2025
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.