PowerScale: Ісілон: OneFS: Швидка автентифікація з NTLMv2 не працює.

Podsumowanie: На Isilon OneFS і PowerScale автентифікація Swift з NTLMv2 не працює. Він працює з NTLMv1. Для використання TLS/SSL з автентифікацією NTLM будь-яка система повинна використовувати NTLMv2. NTLMv1 є старішим і лише звичайним текстом. Реалізація Swift наразі не підтримує NTLMv2 і потребує значної реархітектури для реалізації. Оскільки стороння утиліта Swift як компонент Isilon налаштована на кінець терміну служби і буде видалена в майбутньому випуску, наразі немає планів переробляти нашу платформу та змінювати сторонній код OpenStack Swift для підтримки NTLMv2. Ця стаття стосується всіх версій Isilon OneFS та PowerScale починаючи з версії 9.x і вище. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

За своєю природою не існує зручного або практичного способу перевірити зашифрований (New Technology Lan Manager) трафік NTLMv2 до/від вашого постачальника автентифікації, такого як Active Directory та Isilon. 

Якщо у вас є функціональна реалізація Swift на Isilon, яка добре працює з NTLMv1, увімкнути та переключити вашого постачальника автентифікації на запуск NTLMv2 не вдасться, що буде представлено на стороні Isilon як помилки пароля (LW_ERROR_INVALID_PASSWORD). Іншого практичного способу вивчити це не існує.

Przyczyna

Це пов'язано з обмеженнями в тому, як реалізація OpenStack Swift взаємодіє з Apache та Isilon.

Rozwiązanie

Наразі немає обхідного шляху, і його не очікується через те, що Swift планується як кінець терміну служби на Isilon та PowerScale.

Swift (lwswift) несумісний з NTLMv2

Produkty, których dotyczy problem

Isilon, Data Migration for Isilon, Isilon Platform API
Właściwości artykułu
Numer artykułu: 000199438
Typ artykułu: Solution
Ostatnia modyfikacja: 16 lis 2023
Wersja:  3
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.