Avamar: BŁĄD w menedżerze klienta — "Żądanie ma nieprawidłowy token CSRF" i "TypeError: Dane są niezdefiniowane"

Podsumowanie: Otwieranie menedżera klienta Avamar zgłasza błąd: "Żądanie ma nieprawidłowy token CSRF" i "TypeError: Dane są niezdefiniowane"

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Scenariusz:
tomcat zostanie uruchomiony ponownie.
Pamięć podręczna przeglądarki zostanie wyczyszczona.
Zaloguj się do menedżera klienta i nawiguj do opcji Tab Work/. 
Podczas próby wylogowania się z menedżera klienta pojawia się następujący błąd.
 

dane są niezdefiniowane

Po ponownym otwarciu menedżera klienta monit logowania nie pojawia się i pojawia się ten sam błąd.

Informacje o Avamar wydają się brakować. W podsumowaniu serwera widać komunikat "Nie znaleziono danych".


image.png

Poniżej przedstawiono błąd widoczny w dzienniku ACMTrace:

2022-07-06 15:44:43,340 WARN [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-9]-common.NotificationAction: Notification to action invalidCSRF
022-07-06 15:44:43,342 ERROR [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-9]-filters.AuthenticationFilter: The request has invalid CSRF token, rejecting the request 2022-07-06 15:44:43,633 WARN [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-8]-common.NotificationAction: Notification to action invalidCSRF
2022-07-06 15:44:43,635 ERROR [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-8]-filters.AuthenticationFilter: The request has invalid CSRF token, rejecting the request
2022-07-06 15:49:31,177 INFO [localhost-startStop-2]-listeners.ContextLauncher: Servlet Context Destroyed.
2022-07-06 15:49:34,384 INFO [localhost-startStop-2]-listeners.ContextLauncher: Servlet Context Destroyed.
2022-07-06 15:52:38,931 INFO [localhost-startStop-1]-listeners.ContextLauncher: Servlet Context Launched

 

Przyczyna

Przeglądarka nie zezwala na pliki cookie menedżera aktywacji Avamar.

Rozwiązanie

Zezwalaj na pliki cookie dla Avamar w przeglądarce. Przykładowe instrukcje znajdują się poniżej, ale w razie wątpliwości zapoznaj się z dokumentacją producenta. 

Chrome: 
  1. Otwórz ustawienia Chrome.

  2. Przewiń do dołu i kliknij opcję Zaawansowane.

  3. W sekcji Prywatność i zabezpieczenia kliknij przycisk Ustawienia zawartości.

  4. Kliknij opcję Pliki cookie.

  5. Obok pozycji Zezwalaj kliknij przycisk Dodaj. Wpisz [*.] avamarfqdn (przykład: *.avamarlab.com) i kliknij przycisk "Dodaj".

  6. W obszarze Wszystkie pliki cookie i dane witryny wyszukaj frazę avamar fqdn i usuń wszystkie wpisy związane z avamarfqdn.

  7. Załaduj ponownie Chrome i zaloguj się na stronie menedżera klienta avamar.

Firefox:

  1. Przejdź do menu Preferencje przeglądarki Firefox > prywatności i zabezpieczeń.

  2. W sekcji Historia wybierz opcję "Użyj ustawień niestandardowych dla historii" z menu rozwijanego.

  3. Kliknij opcję Exceptions (Wyjątki) i whitelist avamar FQDN ( przykładowy test).avamar.com)

  4. Przewiń w dół do opcji Site Data (Dane lokalizacji) i kliknij ustawienia obok niego.

  5. Wyszukaj "avamar fqdn" i usuń wszystkie wyświetlane wpisy.

  6. Załaduj ponownie przeglądarkę Firefox i spróbuj zalogować się na stronie menedżera klienta avamar.

Właściwości artykułu
Numer artykułu: 000204692
Typ artykułu: Solution
Ostatnia modyfikacja: 13 lip 2023
Wersja:  2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.