NetWorker: Could not get session key from client-vlan2.domain.com for GSS authentication with server-vlan1.domain.com

Podsumowanie: Multihomed NetWorker clients fail to complete NetWorker GSS authentication. The error reported is "server rejected credential"

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

  • NetWorker file-system backup fails with error:
Unable to set up the direct save with server 'server-vlan2.domain.com': Could not get session key from client-vlan2.domain.com for GSS authentication with server-vlan1.domain.com: Authentication error; why = Server rejected credential.
  • NetWorker server has two IP address one in VLAN1 known as server-vlan1.domain.com and another in VLAN2 known as server-vlan2.domain.com
  • NetWorker client has IP address in VLAN2 known as client-vlan2.domain.com

Przyczyna

  1. Entries for NetWorker server names in servers file missing at client location /nsr/res/servers
  2. Incorrect peer records

Rozwiązanie

  1. Update the client's /nsr/res/servers file with short and Fully Qualified Domain Name (FQDN) for each VLAN of NetWorker server one on each line.
Example:
server-vlan1.domain.com
server-vlan1
server-vlan2.domain.com
server-vlan2

 

  1. Delete peer records corresponding on client and server. See:
    NOTE: Verify short name and FQDN when deleting peer information. Ensure VLAN names for both the client and NetWorker server are included. Any peer certificates found can be removed; once communication is established between the server and client (for example, through backup), new peer certificates are generated.

    Produkty, których dotyczy problem

    NetWorker

    Produkty

    NetWorker Family, NetWorker Series
    Właściwości artykułu
    Numer artykułu: 000212453
    Typ artykułu: Solution
    Ostatnia modyfikacja: 15 sty 2026
    Wersja:  2
    Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
    Usługi pomocy technicznej
    Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.