OpenManage Enterprise: Nie można odtworzyć grupy wtyczek po usunięciu wtyczki usług
Podsumowanie: Klienci korzystający z interfejsów API do tworzenia i usuwania grup wtyczek usług stwierdzają, że jeśli używają interfejsu API OpenManage Enterprise (OME) GroupService (GroupService/Groups(#)) do usuwania grup wtyczek, nie można już zarządzać grupą dodatków usług i nie można jej ponownie utworzyć z powodu błędu "Grupa już istnieje". ...
Objawy
Usunięcie grupy wtyczek usług przy użyciu interfejsu API GroupService/Groups OpenManage Enterprise (OME) powoduje, że grupa nie może być już tworzona przy użyciu interfejsu sieciowego lub interfejsu API tworzenia lub aktualizacji grupy dodatków usług.
Ponowne utworzenie grupy z poziomu sieciowego interfejsu użytkownika powoduje wyświetlenie błędu "Nie można utworzyć lub zaktualizować grupy".
Ponowne tworzenie grupy przy użyciu interfejsu API wtyczek usług (POST /api/SupportAssistService/Actions/SupportAssistService.CreateOrUpdateGroup) zwraca następującą odpowiedź 500:
{
"error": {
"code": "Base.1.0.GeneralError",
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"MessageId": "CGEN6001",
"RelatedProperties": [],
"Message": "Unable to process the request because an error occurred: SAE-020100 : A group with this name already exists. Change the name of this group, then try again..",
"MessageArgs": [
"SAE-020100 : A group with this name already exists. Change the name of this group, then try again."
],
"Severity": "Critical",
"Resolution": "Retry the operation. If the issue persists, contact your system administrator."
}
]
}
}
Przyczyna
Wtyczka Services korzysta z oddzielnej bazy danych zestawu SDK do przechowywania danych opartych na wtyczkach, takich jak inwentaryzacja urządzeń i dane grup. Po utworzeniu grupy dodatków usług szczegóły są przechowywane w bazie danych zestawu SDK przy użyciu unikatowego identyfikatora UID grupy, a następnie informacje o grupie OpenManage Enterprise (OME) są propagowane do bazy danych OpenManage Enterprise (OME) przy użyciu identyfikatora grupy.
Te dwa identyfikatory są powiązane za pomocą atrybutu supportassist.group_saegroup_association w bazie danych OpenManage Enterprise (OME) oraz po usunięciu grupy przy użyciu bazy danych OpenManage Enterprise (OME) GroupService Interfejs API usunięcia nie jest wprowadzany do bazy danych zestawu SDK, pozostawiając osierocone wpisy.
Rozwiązanie
Inżynierowie firmy Dell znają ten problem i zaproponują poprawkę w przyszłej wersji dodatku Services.
Do tego czasu klienci powinni korzystać z interfejsów API wtyczek usług wyłącznie do tworzenia, zarządzania i usuwania grup wtyczek.
Jeśli klient nie może odtworzyć grup, które zostały wcześniej usunięte, należy przeprowadzić eskalację do DE lub IPS, ponieważ FSD będzie wymagane do oczyszczenia oddzielonych grup w bazie danych Services Plugin SDK.