OpenManage Enterprise: Nie można odtworzyć grupy wtyczek po usunięciu wtyczki usług

Podsumowanie: Klienci korzystający z interfejsów API do tworzenia i usuwania grup wtyczek usług stwierdzają, że jeśli używają interfejsu API OpenManage Enterprise (OME) GroupService (GroupService/Groups(#)) do usuwania grup wtyczek, nie można już zarządzać grupą dodatków usług i nie można jej ponownie utworzyć z powodu błędu "Grupa już istnieje". ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Usunięcie grupy wtyczek usług przy użyciu interfejsu API GroupService/Groups OpenManage Enterprise (OME) powoduje, że grupa nie może być już tworzona przy użyciu interfejsu sieciowego lub interfejsu API tworzenia lub aktualizacji grupy dodatków usług.
 
Ponowne utworzenie grupy z poziomu sieciowego interfejsu użytkownika powoduje wyświetlenie błędu "Nie można utworzyć lub zaktualizować grupy".
Ome 
 
Ponowne tworzenie grupy przy użyciu interfejsu API wtyczek usług (POST /api/SupportAssistService/Actions/SupportAssistService.CreateOrUpdateGroup) zwraca następującą odpowiedź 500:
 

{
    "error": {
        "code": "Base.1.0.GeneralError",
        "message": "A general error has occurred. See ExtendedInfo for more information.",
        "@Message.ExtendedInfo": [
            {
                "MessageId": "CGEN6001",
                "RelatedProperties": [],
                "Message": "Unable to process the request because an error occurred: SAE-020100 : A group with this name already exists. Change the name of this group, then try again..",
                "MessageArgs": [
                    "SAE-020100 : A group with this name already exists. Change the name of this group, then try again."
                ],
                "Severity": "Critical",
                "Resolution": "Retry the operation. If the issue persists, contact your system administrator."
            }
        ]
    }
}

 

Przyczyna

Wtyczka Services korzysta z oddzielnej bazy danych zestawu SDK do przechowywania danych opartych na wtyczkach, takich jak inwentaryzacja urządzeń i dane grup. Po utworzeniu grupy dodatków usług szczegóły są przechowywane w bazie danych zestawu SDK przy użyciu unikatowego identyfikatora UID grupy, a następnie informacje o grupie OpenManage Enterprise (OME) są propagowane do bazy danych OpenManage Enterprise (OME) przy użyciu identyfikatora grupy.
 
Te dwa identyfikatory są powiązane za pomocą atrybutu supportassist.group_saegroup_association w bazie danych OpenManage Enterprise (OME) oraz po usunięciu grupy przy użyciu bazy danych OpenManage Enterprise (OME) GroupService Interfejs API usunięcia nie jest wprowadzany do bazy danych zestawu SDK, pozostawiając osierocone wpisy.

Rozwiązanie

Inżynierowie firmy Dell znają ten problem i zaproponują poprawkę w przyszłej wersji dodatku Services.

Do tego czasu klienci powinni korzystać z interfejsów API wtyczek usług wyłącznie do tworzenia, zarządzania i usuwania grup wtyczek.
Jeśli klient nie może odtworzyć grup, które zostały wcześniej usunięte, należy przeprowadzić eskalację do DE lub IPS, ponieważ FSD będzie wymagane do oczyszczenia oddzielonych grup w bazie danych Services Plugin SDK.

Produkty, których dotyczy problem

OpenManage Enterprise Services, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640 , PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Właściwości artykułu
Numer artykułu: 000215072
Typ artykułu: Solution
Ostatnia modyfikacja: 09 wrz 2025
Wersja:  2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.