Openshift: Remove node fails if OperatorHub is configured on disconnected cluster

Podsumowanie: In disconnected environment (cluster in restricted networks or without internet connection), when a user tries to remove a node via Dell APEX Cloud Platform web console plugin, the process fails at step "Check if the node had bare pods". ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Login to Red Hat OpenShift web console, navigate to Inventory tab, select one worker node, and click Actions → Remove worker node, then click Remove button to confirm the action.
The remove process fails at step "Check if the node had bare pod" with error description "The bare pods openshift-marketplace/redhat-operator-index-wltgx cannot be automatically migrated during drain node, please handle them manually."
image.png

Przyczyna

The node remove process will first perform some prechecks before the actual removal starts. The precheck includes a validation whether there are bare pods living in the cluster. If those bare pods exist, user need to handle them manually.
For a cluster in restricted networks or without internet connection, if user configured OperatorHub following SolVe procedure "APEX Cloud Platform for Red Hat OpenShift - Configure OperatorHub procedure" section 3 "Configuring CatalogSource and ImageContentSourcePolicy for OperatorHub on disconnected cluster", it brings the pod "redhat-operator-index-wltgx" into cluster, and it will cause node removal precheck failure.

Rozwiązanie

1. To migrate the pod to other nodes forcibly, user need to drain the node manually.
Note:  please appropriately handle the customer-owned workloads/data on this node before performing the following commands. 
oc adm cordon <target-hostname-to-remove>

oc adm drain <target-hostname-to-remove> --ignore-daemonsets --delete-emptydir-data --force

oc adm uncordon <target-hostname-to-remove>

2. Retry node remove.

Produkty, których dotyczy problem

APEX Cloud Platform for Red Hat OpenShift
Właściwości artykułu
Numer artykułu: 000217681
Typ artykułu: Solution
Ostatnia modyfikacja: 20 lut 2026
Wersja:  3
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.