PowerEdge: Nie można odinstalować lub uaktualnić narzędzia OMSA 11.0.0 do wersji 11.0.1 w systemie ESXi 8.0 Update 1

Podsumowanie: Nie można odinstalować narzędzia OMSA 11.0.0 z powodu błędu "busy", szczególnie w przypadku oprogramowania VMware ESXi 8.0 Update 1. Powoduje to również niepowodzenie uaktualnienia oprogramowania OMSA do wersji 11.0.1 za pośrednictwem interfejsu wiersza poleceń lub programu vCenter Lifecycle Manager ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Dezinstalacja oprogramowania Dell OpenManage Server Administrator (OMSA) 11.0.0 może zakończyć się niepowodzeniem z powodu następującego błędu interfejsu wiersza poleceń:

# esxcli software vib remove -n openmanage
[Exception]
Busy
Please refer to the log file for more details.
Próba uaktualnienia narzędzia OMSA z wersji 11.0.0 do wersji 11.0.1 może spowodować błąd podobny do następującego:
# esxcli software vib install -d <path to OMSA 11.0.1 VIB>
[LiveInstallationError]
 DEL_bootbank_openmanage_11.0.0.0.5268-DEL.700.0.0.15843807: Error in running [/etc/init.d/ompci-watchdog stop upgrade]:
 Return code: 1
 Output: 8.0
 ompcid is not running.

 It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
Użycie programu vCenter Lifecycle Manager do próby zapewnienia zgodności hosta lub klastra hostów ESXi z obrazem bazowym lub klastrem, który nie zawiera już oprogramowania OMSA 11.0.0 lub zawiera oprogramowanie OMSA 11.0.1 przeznaczone do uaktualnienia, może zgłaszać ogólny komunikat "Error = 15. Szczegółowe informacje można znaleźć w dzienniku w monitorze zdarzeń vCenter.

Przyczyna

Problem wynika ze sposobu, w jaki rozwiązanie VMware ESXi 8.0 Update 1 radzi sobie z nieprzydzielaniem pul zasobów za pomocą ompcid procesu po odinstalowaniu dostawcy, takiego jak OMSA.

Rozwiązanie

Firma VMware rozwiązała ten problem dzięki aktualizacji ESXi 8.0 Update 2 i oprogramowaniu OMSA 11.0.0, które można odinstalować, a także poprawnie uaktualnić.

Potencjalnym obejściem problemu jest ręczne ponowne uruchomienie ompcid watchdog w celu zwolnienia zasobów, a następnie ponownej próby dezinstalacji lub aktualizacji po wydaniu następującego polecenia w powłoce ESXi na każdym hoście, którego dotyczy problem:

/etc/init.d/ompci-watchdog restart

Uwaga: Najpierw należy wyłączyć tryb blokady i włączyć opcjonalną powłokę ESXi

Produkty, których dotyczy problem

OpenManage Server Administrator, Dell OpenManage Server Administrator Version 11.0.0.0, VMware ESXi 8.x

Produkty

PowerEdge XR2, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge MX750c, PowerEdge MX760c, PowerEdge R250, PowerEdge R260, PowerEdge R350, PowerEdge R360, PowerEdge R450, PowerEdge R550, PowerEdge R650, PowerEdge R650xs , PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R860, PowerEdge R960, PowerEdge T150, PowerEdge T160, PowerEdge T350, PowerEdge T360, PowerEdge T550, PowerEdge T560, PowerEdge XE2420, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4510c, PowerEdge XR4520c ...
Właściwości artykułu
Numer artykułu: 000218017
Typ artykułu: Solution
Ostatnia modyfikacja: 04 sty 2025
Wersja:  2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.