PowerEdge: Nie można odinstalować lub uaktualnić narzędzia OMSA 11.0.0 do wersji 11.0.1 w systemie ESXi 8.0 Update 1
Podsumowanie: Nie można odinstalować narzędzia OMSA 11.0.0 z powodu błędu "busy", szczególnie w przypadku oprogramowania VMware ESXi 8.0 Update 1. Powoduje to również niepowodzenie uaktualnienia oprogramowania OMSA do wersji 11.0.1 za pośrednictwem interfejsu wiersza poleceń lub programu vCenter Lifecycle Manager ...
Objawy
Dezinstalacja oprogramowania Dell OpenManage Server Administrator (OMSA) 11.0.0 może zakończyć się niepowodzeniem z powodu następującego błędu interfejsu wiersza poleceń:
# esxcli software vib remove -n openmanage [Exception] Busy Please refer to the log file for more details.
Próba uaktualnienia narzędzia OMSA z wersji 11.0.0 do wersji 11.0.1 może spowodować błąd podobny do następującego:
# esxcli software vib install -d <path to OMSA 11.0.1 VIB> [LiveInstallationError] DEL_bootbank_openmanage_11.0.0.0.5268-DEL.700.0.0.15843807: Error in running [/etc/init.d/ompci-watchdog stop upgrade]: Return code: 1 Output: 8.0 ompcid is not running. It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
Użycie programu vCenter Lifecycle Manager do próby zapewnienia zgodności hosta lub klastra hostów ESXi z obrazem bazowym lub klastrem, który nie zawiera już oprogramowania OMSA 11.0.0 lub zawiera oprogramowanie OMSA 11.0.1 przeznaczone do uaktualnienia, może zgłaszać ogólny komunikat "Error = 15. Szczegółowe informacje można znaleźć w dzienniku w monitorze zdarzeń vCenter.
Przyczyna
Problem wynika ze sposobu, w jaki rozwiązanie VMware ESXi 8.0 Update 1 radzi sobie z nieprzydzielaniem pul zasobów za pomocą ompcid procesu po odinstalowaniu dostawcy, takiego jak OMSA.
Rozwiązanie
Firma VMware rozwiązała ten problem dzięki aktualizacji ESXi 8.0 Update 2 i oprogramowaniu OMSA 11.0.0, które można odinstalować, a także poprawnie uaktualnić.
Potencjalnym obejściem problemu jest ręczne ponowne uruchomienie ompcid watchdog w celu zwolnienia zasobów, a następnie ponownej próby dezinstalacji lub aktualizacji po wydaniu następującego polecenia w powłoce ESXi na każdym hoście, którego dotyczy problem:
/etc/init.d/ompci-watchdog restart
Uwaga: Najpierw należy wyłączyć tryb blokady i włączyć opcjonalną powłokę ESXi