Windows Server: Błąd pulpitu zdalnego podczas nawiązywania połączenia z pulpitem zdalnym

Podsumowanie: Podczas próby nawiązania połączenia pulpitu zdalnego z serwerem może pojawić się następujący komunikat o błędzie: "Sesja zdalna została rozłączona, ponieważ nie ma dostępnych serwerów licencji pulpitu zdalnego, które mogłyby dostarczyć licencję". ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Podczas próby nawiązania połączenia pulpitu zdalnego z serwerem może zostać wyświetlony następujący komunikat o błędzie: "Sesja zdalna została rozłączona,

ponieważ nie ma dostępnych serwerów licencji pulpitu zdalnego w celu dostarczenia licencji".

 

  • Menedżer licencjonowania pulpitu zdalnego pokazuje, że licencje dostępu klienta pulpitu zdalnego (RD) (CAL) są zainstalowane na serwerze licencjonowania.
  • Narzędzie Remote Desktop License Diagnostics pokazuje, że używany jest prawidłowy serwer licencjonowania.
  • Przede wszystkim licencje RD CAL wymienione w Menedżerze licencjonowania pulpitu zdalnego nie zawierają wersji systemu operacyjnego, jak pokazano na poniższej ilustracji:
    Zrzut ekranu programu Remote Desktop Licensing Manager przedstawiający licencje CAL bez wersji systemu operacyjnego Rysunek 1. Zrzut ekranu Menedżera licencjonowania pulpitu zdalnego przedstawiający zainstalowane licencje CAL bez wersji systemu operacyjnego

 

Uwaga: Ten artykuł dotyczy jednej konkretnej sytuacji, chociaż ten sam błąd może wystąpić w innych sytuacjach. Zapoznaj się z informacjami w sekcji Objawy, aby potwierdzić, że ten artykuł ma zastosowanie.

Przyczyna

Dzieje się tak, jeśli zainstalowane licencje RD CAL są przeznaczone dla nowszej wersji systemu operacyjnego niż system operacyjny uruchomiony na serwerze licencjonowania usług pulpitu zdalnego. Ten błąd występuje, jeśli na serwerze licencjonowania działa system Windows Server 2019 i zainstalowano licencje RD CAL systemu Windows Server 2022.

Rozwiązanie

Problem ten można rozwiązać na trzy sposoby:
  • Uaktualnij system operacyjny na serwerze licencjonowania, aby był zgodny z wersją zainstalowanych licencji RD CAL. Wymaga to prawidłowej, nieużywanej licencji systemu Windows Server i klucza produktu.
  • Zainstaluj usługę roli licencjonowania pulpitu zdalnego na istniejącym serwerze z nowszym systemem operacyjnym. Zmigruj do niego licencje RD CAL i skonfiguruj wdrożenie usług pulpitu zdalnego tak, aby używało go jako serwera licencjonowania.
  • Skontaktuj się z działem Microsoft Clearinghouse i poproś o przywrócenie licencji RD CAL do wersji uruchomionej na serwerze licencjonowania. Dział pomocy technicznej firmy Dell może pomóc w skontaktowaniu się z działem Microsoft Clearinghouse.

Produkty, których dotyczy problem

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Produkty

C Series, HS Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Właściwości artykułu
Numer artykułu: 000218177
Typ artykułu: Solution
Ostatnia modyfikacja: 09 gru 2024
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.