PowerProtect Data Manager: Wysokie użycie procesora z usługi agenta na hostach Oracle i SQL

Podsumowanie: Usługa agenta PPDM 19.13 na hostach Oracle RMAN i SQL korzysta w dużym stopniu z procesora na hoście.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

1. Na hoście Oracle widzisz usługę agenta korzystającą z procesora w zakresie zbliżonym do 100%.

Śledź wykorzystanie uruchomionego pliku copies.db:

lsof -p <pid>
2. Przejdź do /opt/dpsapps/agentsvc/dbs/v1 i sprawdź, czy rozmiar kopii.db

copies.db będzie bardzo duży, potencjalnie 100 GB

Przyczyna

Ze względu na duży rozmiar bazy danych "copies.db" usługa agenta zajmuje dużo zasobów procesora, aby go zbadać.

Rozwiązanie

W systemie Linux hosty

Oracle 1. Przejdź do /opt/dpsapps/agentsvc

2. Zatrzymaj usługę agenta:

./register.sh --stop

3. Przejdź do /opt/dpsapps/agentsvc/dbs/v1

4. Zmieniono nazwę następujących plików bazy danych:

copies.db
tasks.db
sessions.db

5. Uruchom następujące polecenia:

conn / as sysdba
SQL> exec dbms_stats.gather_fixed_objects_stats();

6.  Wróć do /opt/dpsapps/agentsvc

7.  Uruchom ponownie usługę agenta: Użyj

./register.sh --start

Na hostach Windows SQL:

1. Kliknij przycisk Start i wpisz polecenie services.msc.

2. Zatrzymaj usługę PowerProtect Agent Service.

3. Przejdź do folderu C:\Program Files\DPSAPPS\agentsvc\dbs\v1

4. Zmień nazwę następujących plików bazy danych:

copies.db
tasks.db
sessions.db

5. W apletze Usługi systemu Windows uruchom usługę PowerProtect Agent

Produkty

Data Protection
Właściwości artykułu
Numer artykułu: 000220276
Typ artykułu: Solution
Ostatnia modyfikacja: 09 paź 2024
Wersja:  2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.