NetWorker: "Nie udało się otworzyć pliku blokady: Odmowa uprawnień "Błąd zaobserwowany podczas uruchamiania dowolnego polecenia w nsr

Podsumowanie: Z powodu problemów z uprawnieniami nie można korzystać z żadnych narzędzi wiersza poleceń NetWorker.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Polecenie mminfo kończy się niepowodzeniem z następującym błędem:
136611:mminfo: Failed to open the lock file: Permission denied
144502:nsrd: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.
167325:mminfo: Unable to connect to media database server on host <NW-Server-Name>: Unable to set user privileges based on user token for localadmin on <NW-Server-Name>: Failed to validate security token.

Dotyczy to również nsrcapinfo, nsradmin, nsrlogin, nsrauthtrust itd.

Przyczyna

.administrator.lck nie ma wystarczających uprawnień na hoście serwera NetWorker.

Rozwiązanie

Zmiana uprawnień w pliku blokady nsrlogin w /nsr/tmp/sec/tokens

Windows:

  1. Przejdź do /nsr/tmp/sec/tokens
  2. Znajdź plik ".nsrlogin.localadmin.lck" (jest to plik ukryty, w systemie Windows kliknij opcję wyświetl, a następnie pokaż ukryty).
  3. Zmodyfikuj uprawnienia do pliku dla administratora lokalnego, aby mieć pełną kontrolę.

Linux:

  1. cd /nsr/tmp/sec/tokens
  2.  Wpisz "ls -lat", aby wyświetlić listę wszystkich ukrytych plików i wyświetlić uprawnienia.
  3. Zmodyfikuj uprawnienia plików, aby mieć uprawnienia do odczytu, zapisu i wykonywania.
Właściwości artykułu
Numer artykułu: 000220446
Typ artykułu: Solution
Ostatnia modyfikacja: 23 lut 2024
Wersja:  2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.