Łączność Avamar Data Domain po aktualizacji Cisco Meraki

Podsumowanie: Bez zmian lub aktualizacji do Avamar lub Data Domain połączenie z Data Domain kończy się niepowodzeniem, a zadania przekraczają limit czasu bez postępu.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Błąd w dziennikach Avamar można ujawnić w dziennikach kopii zapasowej systemu plików poprzez utworzenie avtar.cmd w folderze C:\Program Files\avs\var. Utwórz lub edytuj plik avtar.cmd używając Notatnika jako administratora i dodaj poniższe dwie flagi:

 

--debug=true
--x25=-1

 

Potwierdź, że .txt nie jest automatycznie dodawany przez przykład notatnika (avtar.cmd.txt). Zrób to, pokazując rozszerzenia nazw plików za pomocą eksploratora plików systemu Windows.

Usuń filtr avtar.cmd plik po zebraniu dziennika.

avtar Info <41234>: - Connecting to Data Domain Server name "599.499.399.299" with credentials
 [SessionMgr]  SessionMgr::Connect DDRName:599.499.399.299 DDRUser:ddusername DDRPassword:******** handle:0000000002404204 (-1)
 [SessionMgr]  DDRInstance::ctor - ddpInstanceHandle 0x65c6d000
 [SessionMgr]  DDRInstance::Connect: Connecting to DDR: 599.499.399.299
avtar Info <40160>: - Establishing a connection to the Data Domain system with basic authentication (Connection mode: A:0 E:0).
 [SessionMgr]  [DDBoost]-DEBUG	[42C:1404] ddcl_nfs_connect: NFS connect request for bindtype = 0 bind_param = (null)
 [SessionMgr]  [DDBoost]-DEBUG	[42C:1404] ddcl_vrapid_get_host_saddr: host_name 599.499.399.299 needs lookup
 [SessionMgr]  [DDBoost]-DEBUG	[42C:1404] ddcl_get_host_ipv6_ipv4_addr() string IP address found
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] host 599.499.399.299 on IP 599.499.399.299
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] Portmap trying to connect to address 599.499.399.299 
 [SessionMgr]  [DDBoost]-DEBUG	[42C:1404] clnt_async_init_sock: socket init and bind request for bindtype = 0 bind_param = (null)
 [SessionMgr]  [DDBoost]-DEBUG	[42C:1404] clnt_async_tcp_connect: attempting to connect() on port =111 ip=599.499.399.299
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] readtcp: RPC_CANTRECV with errno=Unknown error (10054)
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] clnt_async_call: RPC error= 4 
 [SessionMgr]  [DDBoost]-WARNING	[42C:1404] Port lookup for program 100003 failed. Retry number: 1
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] clnt_process_a_send_job: We have RPC error from previous RPC= 4 
 [SessionMgr]  [DDBoost]-WARNING	[42C:1404] clnt_process_a_send_job RPC error, Will fail all jobs later for status=4
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] clnt_async_call: RPC error= 4 
 [SessionMgr]  [DDBoost]-WARNING	[42C:1404] Port lookup for program 100003 failed. Retry number: 2
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] clnt_process_a_send_job: We have RPC error from previous RPC= 4 
 [SessionMgr]  [DDBoost]-WARNING	[42C:1404] clnt_process_a_send_job RPC error, Will fail all jobs later for status=4
 [SessionMgr]  [DDBoost]-INFO	[42C:1404] clnt_async_call: RPC error= 4  

Przyczyna

System wykrywania włamań (IDS) i system zapobiegania włamaniom (IPS) na urządzeniach Cisco Meraki MX z systemem 18.107.5, 18.107.8, 18.207 sporadycznie blokują ruch Data Domain na porcie 111. Sporadyczne blokowanie ruchu Data Domain na porcie 111 rozpoczęło się wraz z aktualizacją reguły 20240205-1419 i nowszymi. Problem nie wpływa jednakowo na wszystkie urządzenia i może być przerywany nawet w przypadku urządzeń wyświetlających problem.

Rozwiązanie

Zaangażuj pomoc techniczną Cisco, aby skorygować lub wyłączyć regułę. 

Obecnym obejściem problemu jest wyłączenie lub zezwolenie na regułę IDs 1-41185 SunRPC Portmap GETPORT wykryto żądanie, oraz 106-4 RPC_INCOMPLETE_SEGMENT.

Dodatkowe informacje

Produkty, których dotyczy problem

Avamar, Data Domain
Właściwości artykułu
Numer artykułu: 000222090
Typ artykułu: Solution
Ostatnia modyfikacja: 19 lut 2026
Wersja:  2
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.