Błąd logowania do PowerFlex 4.X przy użyciu Scli po nowej instalacji — CERTIFICATE_NOT_YET_VALID

Podsumowanie: Po nowym pomyślnym wdrożeniu grupy zasobów PowerFlex podczas pierwszej próby zalogowania się przy użyciu interfejsu scli logowanie kończy się niepowodzeniem z błędem "CERTIFICATE_NOT_YET_VALID". ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

  • Platforma PowerFlex Manager Platform (PFMP) jest sprawna i funkcjonalna.
  • Nowa grupa zasobów PowerFlex została pomyślnie wdrożona
  • Przy pierwszej próbie logowania logowanie kończy się niepowodzeniem:
[root@l-storage1 ~]# scli --login --username admin --management_system_ip test.powerflex.lab --password xxxxxxx --insecure
Successfully generated login certificate at /root/.scli/cli_cert.p12
Failed to validate certificate /root/.scli/cli_cert.p12. Reason: CERTIFICATE_NOT_YET_VALID
Error: Failed to connect to MDM 127.0.0.1:8611
Wpływ 

Użytkownik nie może administratora zalogować się do węzłów systemu PowerFlex za pomocą interfejsu scli.

Przyczyna

Podczas wdrażania grupy zasobów PowerFlex skonfigurowano NTP, jednak ze względu na problem z kodem oprogramowania węzły nie zostały skonfigurowane z NTP, co spowodowało, że data/godzina w węzłach PowerFlex była starsza.
 

Uwaga: Ten problem występuje tylko w przypadku korzystania z obrazu systemu operacyjnego CentOS 7 / Red Hat 7 (nazwa obrazu: "DellEMC-PowerFlex-EmbeddedOS-7-x86_64.iso") podczas wdrażania, ale może to mieć wpływ na inne obrazy systemu operacyjnego.

Rozwiązanie

Skonfiguruj ręcznie datę/godzinę lub NTP na każdym węźle PowerFlex i ponów próbę zalogowania.

Etapy dodawania danych wewnętrznego serwera NTP klienta do pliku chrony.conf

  1. Wpisz następujące polecenie, aby wejść do edytora:
    vi /etc/chrony.conf
  2. Użyj klawisza "I", aby przejść do trybu wstawiania
  3. Użyj strzałki w górę, aby poruszać się kursorem pod wierszem "# Użyj serwerów publicznych z projektu pool.ntp.org".
  4. Naciśnij klawisz Enter, aby rozpocząć nowy wiersz
  5. Wpisz dane serwera NTP klienta 
    server <NTP IP Address or server name> iburst
    Example: server 10.10.105.240 iburst
  6. Naciśnij klawisz Esc, aby wyjść z trybu wstawiania, a następnie wpisz " : wq"  Aby zapisać i zamknąć Edytor VI
  7. Użyj tego polecenia, aby sprawdzić, czy dodano nowy wiersz:
    cat /etc/chrony.conf | grep server
  8. Po upewnieniu się, że ustawienia NTP są poprawne, uruchom ponownie usługę chronyd.
    systemctl restart chronyd
  9. Sprawdź, czy usługa została pomyślnie uruchomiona ponownie:
    systemctl status chronyd
  10. Po pomyślnym ponownym uruchomieniu usługi sprawdź, czy NTP wyświetla teraz komunikat o połączeniu.
    chronyc tracking
  11. Gdy usługa NTP pokaże, że jest podłączona, spróbuj zalogować się ponownie
    scli --login --management_system_ip [PFxM ingress IP] --username admin
Uwaga: Powyższe kroki należy wykonać na wszystkich serwerach SDS, zwłaszcza tych z rolami MDM, aby upewnić się, że będą one w stanie pomyślnie połączyć się z certyfikatami.

 

Wersja, której dotyczy problem

PowerFlex 4.x

Naprawiono w wersji

PowerFlex 4.6.1 

Dodatkowe informacje

Wersja, której dotyczy problem

PowerFlex 4.x

Naprawiono w wersji

PowerFlex 4.6.1

Właściwości artykułu
Numer artykułu: 000223736
Typ artykułu: Solution
Ostatnia modyfikacja: 12 mar 2026
Wersja:  7
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.