PowerStore: Po uaktualnieniu do systemu PowerStoreOS 4.1 w klastrach z co najmniej trzema urządzeniami replikacja bazy danych zarządzania może pozostać w trybie asynchronicznym

Podsumowanie: Po uaktualnieniu systemu PowerStoreOS do wersji 4.1 w klastrze z co najmniej trzema urządzeniami klaster może nie włączyć ponownie replikacji synchronicznej wewnętrznej bazy danych zarządzania. W takim przypadku replikacja bazy danych zarządzania w klastrze, którego dotyczy problem, pozostaje w trybie asynchronicznym. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Po uaktualnieniu do wersji 4.1 wewnętrzna baza danych zarządzania nie powraca do replikacji synchronicznej i pozostaje asynchroniczna.

Uwaga: Ten problem nie dotyczy klastrów z jednym urządzeniem ani klastrów z dwoma urządzeniami.

Ta zmiana nie powinna mieć bezpośredniego wpływu na funkcjonalność klastra ani na dane użytkowników, ponieważ zmiany są replikowane na wszystkich urządzeniach.

Potencjalny warunek integralności danych może zostać wyzwolony w bazie danych zarządzania klastra z co najmniej trzema urządzeniami po zdarzeniu przełączania awaryjnego urządzenia (takim jak wyłączenie na poziomie urządzenia lub awaria zasilania na poziomie urządzenia).

Przyczyna

Ze względu na problem z oprogramowaniem w wersji 4.1 (lub nowszej) replikacja bazy danych zarządzania w klastrze z co najmniej trzema urządzeniami nie powraca do replikacji synchronicznej po zakończeniu uaktualnienia i pozostaje asynchroniczna.

Wpływ

Jeśli urządzenie podstawowe nagle ulegnie awarii lub rozłączy, a istnieją oczekujące polecenia zarządzania, które nie zostały jeszcze wysłane do co najmniej jednego urządzenia dodatkowego, w bazie danych zarządzania klastra, którego dotyczy problem, może zostać wyzwolony warunek integralności danych.

Rozwiązanie

Ten problem został rozwiązany w systemach PowerStoreOS w wersjach 4.1.0.1 oraz 4.2 i nowszych. 

 

Skontaktuj się z działem pomocy technicznej firmy Dell , aby potwierdzić wystąpienie tego problemu. Zapoznaj się z tym identyfikatorem artykułu bazy wiedzy, aby uzyskać przyspieszoną obsługę.

 

Uwaga: Wraz z wydaniem pakietu PowerStore Health Check 4.1 wprowadzono nową funkcję kontroli poprawności działania przed aktualizacją (PUHC) w celu identyfikacji klastrów urządzeń z 3 lub 4 urządzeniami PowerStore.  Nowa kontrola z flagą takich systemów spowoduje niepowodzenie PUHC w PowerStoreOS w wersji 4.1.

Ekran szczegółów zadania

Produkty, których dotyczy problem

PowerStore
Właściwości artykułu
Numer artykułu: 000286668
Typ artykułu: Solution
Ostatnia modyfikacja: 25 wrz 2025
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.