Data Domain: Weryfikacja i konfiguracja synchronizacji czasu CIFS i NTP

Podsumowanie: W tym artykule wyjaśniono, jak zarządzać synchronizacją czasu w systemach zintegrowanych z usługą Active Directory (AD). Obejmuje czynności umożliwiające weryfikację konfiguracji synchronizacji czasu, wykrywanie potencjalnych konfliktów między protokołem NTP (Network Time Protocol) a kontrolą czasu AD. Zapewnia również polecenia umożliwiające wyłączenie synchronizacji czasu CIFS (Common Internet File System) i zapewnienie właściwego zarządzania czasem. Obejmuje również czynności sprawdzania poprawności konfiguracji za pomocą dzienników i kontroli stanu systemu. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

  • Nieoczekiwane zmiany czasu systemowego
  • Błędy uwierzytelniania lub Kerberos
  • Dryfy czasowe między systemami domenowymi
  • Aktualizacje dotyczące czasu konfliktu z NTP i AD
  • Wpisy dziennika pokazujące częste korekty czasu (ADSyncTimeToDC)

Przyczyna

Zarówno NTP, jak i Active Directory próbują kontrolować czas systemowy, co prowadzi do konfliktów. Jeśli synchronizacja czasu CIFS jest włączona wraz z NTP w systemach zintegrowanych z usługą AD, może to powodować dryfy czasowe, problemy z uwierzytelnianiem i niestabilność systemu.

Rozwiązanie

Wykonaj następujące czynności, aby zidentyfikować i rozwiązać konflikty synchronizacji czasu w systemach zintegrowanych z usługą Active Directory:

  1. Sprawdź, czy system jest przyłączony do usługi Active Directory:
Uruchom następujące polecenie:
cifs troubleshooting domaininfo
Poszukaj wiersza:
[Authentication provider: lsa-activedirectory-provider]
Jeśli ten dostawca znajduje się na liście, oznacza to, że system używa usługi Active Directory do uwierzytelniania i może również otrzymywać od niego synchronizację czasu. Te informacje można uzyskać na stronie Autosupports.
  1. Sprawdzanie stanu NTP:
Uruchom:
ntp status

Example output:

Status                                     Enabled
Current Clock Time                         Fri Mar 14 11:04:17.535 2025
Clock Last Synchronized                    Fri Mar 14 10:53:04.617 2025
Clock Last Synchronized With Time Server   10.92.32.52
Jeśli protokół NTP jest włączony, gdy system jest przyłączony do usługi AD, może to powodować konflikty synchronizacji czasu.
  1. Przejrzyj dzienniki synchronizacji czasu:
Uruchom następujące polecenie, aby sprawdzić zmiany czasu wyzwalane przez usługę AD:
grep ADSync cifs.log

Example output:

Mar  4 02:41:26 aurdd5246 lsass: ALWAYS: [24531/...] [lsass] ADSyncTimeToDC: Attempting to change System Time, from [Tue Mar  4 02:41:26 2025 ] to [Fri May  2 20:19:46 2025 ]
May  2 20:34:46 aurdd5246 lsass: ALWAYS: [24531/...] [lsass] ADSyncTimeToDC: Attempting to change System Time, from [Fri May  2 20:34:46 2025 ] to [Tue Mar  4 02:56:25 2025 ]
Te wpisy wskazują, że usługa Active Directory próbuje kontrolować czas systemowy, co może powodować konflikt z NTP, jeśli oba są włączone.
  1. Określ ścieżkę rozwiązania:
  • Jeśli skonfigurowano usługę AD i włączono protokół NTP, oznacza to błędną konfigurację.
Aby uniknąć konfliktów czasowych:

Wyłącz NTP i zezwól usłudze Active Directory na zarządzanie czasem systemowym.

  • Jeśli aktywna jest tylko jedna metoda (NTP lub AD), nie są wymagane żadne działania.
System jest prawidłowo skonfigurowany.

Produkty, których dotyczy problem

Data Domain
Właściwości artykułu
Numer artykułu: 000305261
Typ artykułu: Solution
Ostatnia modyfikacja: 01 maj 2026
Wersja:  4
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.