PowerScale: Wpływ zamrożenia platformy Microsoft Azure na system Virtual PowerScale OneFS
Podsumowanie: Czy zamrożenie platformy Azure ma wpływ na rozwiązanie Virtual PowerScale OneFS na platformie Microsoft Azure?
Objawy
Firma Dell nie ma kontroli ani uprawnień z punktu widzenia i poziomu OneFS w odniesieniu do zdarzeń zawieszania się, jeśli takie wystąpią. Warstwa hiperwizora (Azure) całkowicie zarządza i kontroluje to. Firma Dell ma ograniczone możliwości raportowania wykrytych incydentów związanych z zamrożeniem.
Zdarzenie zamrożenia z poziomu platformy Windows Azure jest niezależne od ekosystemu i infrastruktury OneFS oraz poza nim. Na wewnętrzne operacje OneFS nie mają wpływu działania zewnętrzne, na które nie mamy wpływu ani nie mamy wpływu. To nie jest problem z kodem OneFS. Poziom wirtualny OneFS odbiera sygnał z poziomu platformy Azure powiadamiający go o zdarzeniu zamrożenia. Następnie (po zamrożeniu) OneFS dostarcza powiadomienie o podanych informacjach. Zamrożenie może chwilowo wstrzymać procesory i dostęp do sieci w określonym węźle. Nie ma to wpływu na wewnętrzne operacje OneFS. Jednak aktywne operacje sieciowe w węźle mogą zostać na krótko przerwane, a nowe połączenia podczas zamrożenia mogą zakończyć się niepowodzeniem.
Przyczyna
Rzeczy takie jak zawieszanie się są nieodłączną częścią powiązanych systemów firmy Microsoft:
https://learn.microsoft.com/en-us/azure/virtual-machines/maintenance-and-updates
Rozwiązanie
Z punktu widzenia OneFS nie jest możliwe żadne działanie dotyczące zawieszania się. Jeśli zdarzy się, że wykryjesz problem związany z zawieszaniem się, który ma wpływ na:
- Otwórz zgłoszenie do pomocy technicznej w klastrze.
- Cytuj ten artykuł bazy wiedzy bezpośrednio.
- Poproś o przekazanie sprawy do zespołu "Admin" w pomocy technicznej OneFS w celu wstępnej oceny.