Data Domain: Problem z aktualizacją oprogramowania wewnętrznego dysku w DDOS 7.x | 8,0 | 8.1| 8,2 | 8.3.0.x

Podsumowanie: W systemach DDOS w wersjach 7.10, 7.13, 8.0, 8.1, 8.2, 8.3.0.x w systemach Data Domain (DD) z włączonymi aktualizacjami oprogramowania wewnętrznego napędów mogą wystąpić nieoczekiwane, fałszywe awarie dysków. W szczególności dwa urządzenia na grupę dysków (DG) mogą przejść w stan awarii z powodu problemu z liczbą odwołań modułu RAID w jądrze. Może to prowadzić do niestabilności systemu i potencjalnego zagrożenia dostępności danych. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

  • Dwa urządzenia na grupę urządzeń (DG) nieoczekiwanie przechodzą w stan awarii
  • Próba awarii trzeciego urządzenia w jednostce głównej powoduje awarię systemu (stan Total Fail)
  • Nadmierne kern.info Wpisy w dzienniku WARN
  • Stan zdegradowanej grupy dysków
  • Zauważalne pogorszenie wydajności DD

Systemy, których dotyczy problem:

  • Systemy DD z zewnętrzną pamięcią masową z wczesnymi wersjami DDOS 7.10 | 7.13 | 8,0 | 8.1 | 8,2 | 8.3.0.x

Przyczyna

Podczas procesu aktualizacji oprogramowania wewnętrznego dysku polecenie RAID check scan Może być wykonywana wielokrotnie w zależności od liczby urządzeń w systemie. Każde wykonanie zwiększa liczbę odwołań modułu RAID w jądrze Linuksa. W jądrach w wersjach 4.4 i 5.4 (używanych w DDOS 7.7, 7.10, 7.13, 8.0, 8.1, 8.2 i 8.3.0.x) ta liczba odwołań nie zmniejsza się. Jeśli liczba ta spadnie do zera, jądro zablokuje macierzy RAID dostęp do wewnętrznych gendisk struktury, powodując, że urządzenia są oznaczane jako nieczytelne i przenoszone do stanu uszkodzonego. Każda DG toleruje tylko dwa uszkodzone urządzenia; trzecia awaria wyzwala awarię systemu w jednostce głównej (kontrolerze).

Rozwiązanie

Trwała poprawka została zintegrowana z następującymi wersjami DDOS:

  • Wydania LTS: 
    • 7.10.1.70 ||  7.13.1.30 || 8.3.1.0 (lub nowsza)
  • Wydane funkcje:
    • >= 8.4.0.x

Obejście problemu:

  • Jeśli uaktualnienie nie jest możliwe.
  • Do wykonania przez dział pomocy technicznej firmy Dell:
    • Zmodyfikuj skrypt aktualizacji oprogramowania wewnętrznego dysku tak, aby powracał natychmiast po wykonaniu, minimalizując wzrost liczby odwołań modułu RAID.
  • Klienci: Wyślij zgłoszenie serwisowe do działu pomocy technicznej firmy Dell i zapoznaj się z tym artykułem bazy wiedzy (#000331892), aby przyspieszyć rozwiązanie.

Produkty, których dotyczy problem

Data Domain
Właściwości artykułu
Numer artykułu: 000331892
Typ artykułu: Solution
Ostatnia modyfikacja: 07 sty 2026
Wersja:  6
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.