PowerFlex: Przywracanie PFMP z kopii zapasowej nie powiodło się, gdy hasło nie jest zakodowane w formacie Base64

Podsumowanie: Podczas przywracania platformy PowerFlex Manager Platform (PFMP) proces zostaje przerwany, ponieważ skrypt oczekuje CIFS i haseł szyfrowania w postaci zakodowanej w formacie base64. Podanie zwykłych haseł powoduje niepowodzenie. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Podczas przywracania programu PowerFlex Manager z kopii zapasowej hasła muszą być w formacie zakodowanym w formacie base64

 

Przykład błędu, gdy hasło szyfrowania jest nieprawidłowe lub nie jest poprawnie zakodowane 


  

Przykład błędu, gdy hasło szyfrowania nie jest zakodowane

 

Przykład błędu, gdy hasło CIFS jest nieprawidłowe lub nie jest poprawnie zakodowane 

Przykład błędu, gdy hasło CIFS nie jest zakodowane

Przyczyna

Użytkownik wprowadził zwykłe hasło, a nie zakodowane hasło w poniższych krokach

Please enter CIFS password(base64 encoded). Press enter to skip if username is not required: 

Please enter encryption password for backup file (base64 encoded): 

Rozwiązanie

Uruchom następujące polecenie, aby zakodować hasło w formacie zakodowanym w formacie base64. 

echo -n 'MyPassword' | base64

Zastąp Mypassword , które ma być zakodowane

Pamiętaj o następujących kwestiach:

  • Umieść hasło między 2 pojedynczymi cudzysłowami ' '
  • Użyj argumentu -n w poleceniu echo, aby uniknąć końcowego znaku nowej linii 

Przykład:

 Przykład kodowania hasła   

W tym przykładzie hasło zostało zakodowane w cGFzc3dvcmQ=

 

Uruchom ponownie skrypt przywracania i upewnij się, że po wyświetleniu monitu używasz nowego zakodowanego hasła, a nie zwykłego hasła 

Please enter CIFS password(base64 encoded). Press enter to skip if username is not required: cGFzc3dvcmQ=

Please enter encryption password for backup file (base64 encoded): cGFzc3dvcmQ=

Dodatkowe informacje

Pełne kroki przywracania programu PowerFlex Manager można znaleźć w następującym podręczniku Dell PowerFlex Manager 4.8.x User Guide , którego kopia znajduje się również poniżej. 

 

 

  • Przywracanie programu PowerFlex Manager

Przywrócenie programu PowerFlex Manager przywraca utworzone przez użytkownika dane do wcześniejszej konfiguracji zapisanej w pliku kopii zapasowej. Aby przywrócić dane z kopii zapasowej, należy uruchomić skrypt spoza programu PowerFlex Manager. Interfejs użytkownika nie obsługuje przywracania z kopii zapasowej.

Wymagania wstępne

Przed rozpoczęciem procedury przywracania należy spełnić następujące wymagania wstępne:

  • Klaster przywracania musi mieć dokładnie taką samą wersję PowerFlex i Kubernetes.
  • Klaster przywracania musi mieć dokładnie takie same adresy IP i konfigurację.

    Konfiguracja klastra musi być taka sama jak konfiguracja klastra, w którym wykonano kopię zapasową.

    • Wszystkie węzły Kubernetes muszą mieć te same adresy IP.
    • Wszystkie węzły Kubernetes muszą mieć takie same nazwy.
    • Wszystkie adresy IP LoadBalancer muszą być takie same.
Informacje o tym zadaniu
Przestroga: Przywrócenie wcześniejszej konfiguracji powoduje ponowne uruchomienie programu PowerFlex Manager i usunięcie danych utworzonych po utworzeniu pliku kopii zapasowej, do którego odbywa się przywracanie. Wszystkie uruchomione zadania również mogą zostać zakończone.
Kroki
  1. Zaloguj się do węzła, w którym początkowo uruchomiono instalator platformy PowerFlex Manager.
  2. Uruchom skrypt przywracania dołączony do pakietu instalatora:
./restore_backup.sh
  1. W razie potrzeby podaj szczegóły, aby zakończyć wykonanie skryptu.
    Zostanie wyświetlony monit o podanie nazwy użytkownika i hasła SSH. Ponadto zostanie wyświetlony monit o określenie, czy hasła są takie same dla wszystkich węzłów, a także podanie lokalizacji pliku kopii zapasowej i zaszyfrowanego hasła do pliku. Może pojawić się prośba o podanie nazwy użytkownika i hasła CIFS. Poświadczenia CIFS mogą nie być wymagane w przypadku udziału CIFS, który umożliwia dostęp anonimowy.
     
    Uwaga: Hasła muszą być w formacie zakodowanym w formacie base64.

    Aby zakodować hasło w base64, użyj następującego polecenia 

    echo -n 'MyPassword' | base64

    Zastąp Moje hasło, które ma być zakodowane, upewnij się, że umieściłeś hasło między 2 pojedynczymi qoutes ' '

    Przykład:

    echo -n 'example' | base64
    ZXhhbXBsZQ==
    

    Aby zakończyć wykonywanie skryptu przywracania, należy określić, czy operacja przywracania zostanie wykonana w istniejącym, czy nowym klastrze.

    Oto fragment kodu przedstawiający przykładowy przebieg skryptu przywracania:

    [root@sheetal-installer scripts]# ./restore_backup.sh
    
    /usr/local/lib/python3.8/site-packages/paramiko/transport.py:236: CryptographyDeprecationWarning: Blowfish has been deprecated "class": algorithms.Blowfish, Installation logs are available at <Bundle root>/PFMP_Installer/logs/ directory. More detailed logs are available at <Bundle root>/atlantic/logs/ directory. PFMP Installer is about to reset a PFMP cluster based on the configuration specified in the PFMP_Config.json.
    
    Please enter the ssh username for the nodes specified in the PFMP_Config.json[root]:root
    
    Are passwords the same for all the cluster nodes[Y]?:Y
    
    Please enter the ssh password for the nodes specified in the PFMP_Config.json. Password:
    
    Please enter backup file location - Example CIFS: \\1.2.3.4\Lab\backup\file.tgz
    
    Please enter CIFS username. Press enter to skip if username is not required:administrator
    
    Please enter CIFS password(base64 encoded). Press enter to skip if username is not required: UmFpZDR1cyE=
    
    Please enter encryption password for backup file (base64 encoded): UmFpZDR1cyE=
    
    Perform restore on existing cluster? Please enter yes/y or no/n :
    
        
Wyniki

Proces przywracania drukuje informacje o stanie do momentu zakończenia procesu przywracania.

Produkty, których dotyczy problem

PowerFlex rack, ScaleIO
Właściwości artykułu
Numer artykułu: 000464562
Typ artykułu: Solution
Ostatnia modyfikacja: 18 maj 2026
Wersja:  3
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.