VPLEX: Solução de problemas de conectividade do provedor de gerenciamento de array (AMP)

Resumo: Etapas de solução de problemas quando o status de conectividade do AMP é exibido como "inacessível" e/ou quando o registro de um AMP falha com o erro "Failed to ping AMP.... Causa: Não foi possível conectar'. ...

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Sintomas

  • Possíveis alterações na rede do cliente
  • Alteração da configuração do firewall
  • Alterações no host AMP
  • O status de conectividade do AMP informa como "inacessível"
    /clusters/cluster-1/storage-elements/array-providers/AMP_NAME
    
    Attributes:
    Name Value
    ------------------- ------------
    array -
    connectivity-status unreachable
    ip-address X.X.X.X
    port 5989
    provider-type SMI-S
    use-ssl true
    username admin
  • A tentativa de registrar um AMP falha com a seguinte mensagem de erro:
    amp register: Evaluation of <<amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c cluster-1>> failed.
    cause: Failed to register array management provider.
    cause: Failed to ping AMP 'AMP_NAME'. com.emc.vplex.via.orca.amp.AMPException: Failed to ping provider 'AMP_NAME'. Cause: Unable to connect

 

Causa

  • Problemas de conectividade IP entre o servidor de gerenciamento/MMCS do VPlex e o host AMP.
  • Alterações nas regras de firewall existentes
  • Alteração de credenciais no provedor SMI-S

 

Resolução

  1. Faça ping no endereço IP do host AMP do servidor de gerenciamento (VS2) ou do MMCS (VS6) para garantir que seja possível fazer ping. Se não for possível fazer ping do IP, certifique-se de que todos os problemas de conectividade entre o servidor de gerenciamento/MMCS do VPlex sejam resolvidos;

    service@ManagementServer:~> ping X.X.X.X
  2. Se o status de conectividade da configuração de AMP existente for indicado como "inacessível", cancele o registro da configuração do VPlexcli e registre-a novamente;

    VPlexcli:/> amp unregister -n AMP_NAME -c cluster-1
    Unregistering an array-provider will permanently remove it. Do you wish to proceed? (Yes/No) Yes
    Successfully unregistered array provider 'AMP_NAME' on cluster 'cluster-1'.
  3. Durante o registro do AMP, uma URL é criada usando três valores: protocolo, host e porta. O servidor de gerenciamento/MMCS tenta se conectar a essa URL durante o processo de registro. Se esse URL estiver inacessível, o registro do AMP apresentará falha. O protocolo usado pelo servidor ECOM é HTTP (5988) ou HTTPS (5989). Ambas as portas, juntamente com a porta 443, devem estar abertas em ambos os directors (entrada e saída) na configuração do firewall. Para obter uma lista de todas as exceções de firewall, consulte o anexo em PDF na parte inferior deste artigo denominado "Provisioning with EMC VIAS.pdf";

    Considerações sobre o firewall do SMI-S para VIAS Pág. 12
    Criando regras de firewall TCP Pág. 13
    Configuração de segurança do ECOM (credenciais) Pág. 13
  4. Para verificar se as portas estão abertas, execute um telnet para o IP do AMP especificando as portas do management-server/MMCS. Se qualquer uma das portas usadas estiver bloqueada, consulte a etapa 3 acima para garantir que as portas relevantes estejam abertas/permitidas no firewall;

    Instância em que a porta 5988 está bloqueada:

    service@ManagementServer:~> telnet X.X.X.X 5988
    Trying X.X.X.X...
    telnet: connect to address X.X.X.X: Connection timed out

    Instância em que a porta 5989 está aberta:

    service@essvplex0415-mc:/var/log/VPlex/cli> telnet X.X.X.X 5989
    Trying X.X.X.X...
    Connected to X.X.X.X.
    Escape character is '^]'.
    Connection closed by foreign host.
  5. Ao tentar registrar o AMP usando HTTPS (porta 5989), certifique-se de que o argumento --use-ssl esteja especificado;

    VPlexcli:/> amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c CLUSTER_ID --use-ssl
  6. As credenciais padrão de administrador para registrar o AMP são as seguintes (essa não é a senha de administrador do VPlex!)

    Usuário: admin
    Senha: #1Password

  7. Se todas as etapas acima não conseguirem corrigir o problema, considere reinicializar o host AMP e tente registrar o AMP. Se o processo de registro ainda falhar, crie um chamado com a Dell.

 

Produtos afetados

VPLEX GeoSynchrony

Produtos

VPLEX VS2, VPLEX VS6
Propriedades do artigo
Número do artigo: 000050148
Tipo de artigo: Solution
Último modificado: 17 abr. 2026
Versão:  5
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