Como resolver uma situação de alto uso da CPU com o processo Dell.Genoa.Agent.exe e Dell.Genoa.UserProcess.exe quando o Dell SupportAssist for Business está instalado
Resumo: Quando o Dell SupportAssist for Business é instalado com o processo Dell.Genoa.Agent.exe e Dell.Genoa.UserProcess.exe, o computador pode apresentar alto uso da CPU.
Sintomas
Produtos afetados:
- Dell Insights
- Dell SupportAssist for Business
Versões afetadas:
- v2.1.4 ou anterior
Plataformas afetadas:
- Windows 10
O Dell SupportAssist for Business contém um componente denominado Dell Insights, que extrai várias informações de telemetria do endpoint para os administradores usarem no console do Dell TechDirect. Esses dados de telemetria são obtidos por meio de vários contadores de desempenho do Windows e, em raras situações, esses contadores de desempenho podem ficar corrompidos. Este artigo discute os métodos para redefinir esses contadores e resolver problemas que podem ser provenientes de contadores de desempenho corrompidos ou danificados do Windows.
Causa
Em situações raras, os contadores de desempenho do Windows podem ser corrompidos ou danificados, fazendo com que o processo Dell.Genoa.Agent.exe ou Dell.Genoa.UserProcess.exe, que consome recursos pesados, ocorra. Os computadores afetados mostram alto uso da CPU com os processos Dell.Genoa.Agent.exe ou Dell.Genoa.UserProcess.exe. O alto uso da memória (mais de 500 MBs) também é uma causa.
Resolução
Os contadores de desempenho do Windows podem ser liberados para resolver o problema. As etapas a seguir devem ser realizadas para garantir que os dados sejam devidamente liberados. No final do artigo, há um exemplo de script que pode ser usado em um arquivo.bat. Em caso de dúvidas ou problemas com a execução manual do processo, entre em contato com o Dell ProSupport.
- Interrompa o serviço Dell Insights Agent.
- Sintaxe de exemplo:
net stop DellInsightsAgent
- Sintaxe de exemplo:
- Faça a liberação dos contadores de desempenho do Windows.
- Sintaxe de exemplo (sistema operacional de 32 bits):
C:\Windows\system32\lodctr.exe /R - Sintaxe de exemplo (sistema operacional de 64 bits):
C:\Windows\syswow64\lodctr.exe /R
- Sintaxe de exemplo (sistema operacional de 32 bits):
lodctrdeve ser feita duas vezes, dependendo do estado do dispositivo. A Dell recomenda executar lodctr, fazer flush dos contadores de desempenho da WMI e, em seguida, executar novamente lodctr . Para obter mais informações sobre os contadores de desempenho do Windows, consulte https://support.microsoft.com/en-us/help/300956/how-to-manually-rebuild-performance-counter-library-values
- Faça a liberação dos contadores de desempenho da WMI.
- Sintaxe de exemplo:
winmgmt.exe /resyncperf
- Sintaxe de exemplo:
- Reinicie o serviço WMI.
- Sintaxe de exemplo:
net stop Winmgmt /y
- Sintaxe de exemplo:
- Remova todos os logs existentes do Dell Insights.
- Sintaxe de exemplo:
RMDIR /s /q "C:\ProgramData\Dell\Dell Insights\"
- Sintaxe de exemplo:
Re-Start the Dell Insights Agent service.- Sintaxe de exemplo:
net start DellInsightsAgent
- Sintaxe de exemplo:
Exemplo de script
::creating logging directory mkdir C:\ProgramData\Dell\InsightsLogging\ ::starting logging ECHO "" >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ECHO Flushing Performance Counters >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ECHO %DATE%%TIME% >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log :stopping Insights service net stop DellInsightsAgent >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::killing process in case the service fails to stop (can happen when in a loop) taskkill /im Dell.Genoa.Agent.exe /f >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::flushing performance counters C:\Windows\system32\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log C:\Windows\syswow64\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log winmgmt.exe /resyncperf >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::stopping services net stop Winmgmt /y >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::re-flushing to validate caches are truly flushed C:\Windows\system32\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log C:\Windows\syswow64\lodctr.exe /R >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log winmgmt.exe /resyncperf >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::re-starting services net start Winmgmt >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log net start vmms >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log net start CcmExec >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log net start iphlpsvc >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::purging logs RMDIR /s /q "C:\ProgramData\Dell\Dell Insights\" >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log ::re-starting insights agent net start DellInsightsAgent >> C:\ProgramData\Dell\InsightsLogging\FlushLogging.log
- A execução precisa ser feita como administrador.
- Exibe o status de cada item de linha durante o processo
- Redefine todos os contadores de desempenho do Windows
- Libera os logs existentes do Dell Insights Agent, que faz parte do Dell SupportAssist for Business
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