OMSA: 10.1 Não responde a consultas de WMI e SNMP do DELL_CM

Resumo: O Dell OpenManage Server Administrator 10.1.0 e posterior não responde mais a consultas diretas de WMI ou SNMP de seis classes DELL_CMxxxx de vários itens de inventário do sistema. Isso se deve à decisão da engenharia da Dell de remover o módulo Inventory Collector (IC) subjacente por restrições de tamanho de pacote de instalação e segurança. ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

A consulta das seguintes classes do Dell OpenManage Server Administrator (OMSA) 10.1.0 e posterior agora retorna resultados nulos:

  • DELL_CMApplication
  • DELL_CMDevice
  • DELL_CMDeviceApplication
  • DELL_CMInventory
  • DELL_CMOS
  • DELL_CMProductInfo

Essas classes fornecem várias informações de inventário, como as versões atuais de firmware e driver dos componentes do sistema, informações básicas do sistema operacional e assim por diante.

Causa

A engenharia da Dell decidiu não ter mais o pacote do módulo Inventory Collector (IC) devido às versões desatualizadas restantes no OMSA, ao grande tamanho da instalação e às restrições de largura de banda e às preocupações de segurança. Nos anos anteriores, o IC era o suporte principal do Dell IT Assistant e do Dell OpenManage Essentials. O OMSA 9.5 foi a última versão a agrupar o IC. Ambos os produtos não têm suporte e foram substituídos pelo Dell OpenManage Enterprise, que depende do iDRAC para esse inventário em vez do OMSA.

Resolução

Se os dados de inventário dessas classes ainda forem necessários para a programação direta de WMI ou SNMP com o OMSA, faça download e instale manualmente o módulo IC nos caminhos a seguir. O Serviço Compartilhado OMSA deve então ser ativado e reiniciado:

Windows:

  1. Crie as pastas "cm" e "invcol" dentro C:\Program Files\Dell\SysMgt\
  2. Baixar IC para Windows em: https://downloads.dell.com/FOLDER07847532M/1/invcol_8YPK7_WIN64_21_12_200_1196_A00.exe
  3. Renomeie o download para invcol.exe e mova para C:\Program Files\Dell\SysMgt\cm\invcol\
  4. Reinicie o DSM SA Shared Services e aguarde até 10 minutos para que o IC conclua seu inventário inicial.

Linux:

  1. Download do IC para Linux em: https://downloads.dell.com/FOLDER07847525M/1/invcol_8YPK7_LN64_21_12_200_1196_A00.BIN
  2. Renomeie para invcol e mover para /opt/dell/srvadmin/sbin/lx64/.
  3. No prompt do shell, execute o comando: 
srvadmin-services restart

Produtos afetados

OpenManage Server Administrator, Dell OpenManage Server Administrator Version 10.1.0.0, OEMR R240, OEMR R250, OEMR XE R250, OEMR R260, OEMR XE R260, OEMR R340, OEMR R350, OEMR XE R350, OEMR R360, OEMR XE R360, OEMR R440, PowerEdge XR2, OEMR R450 , OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR XL R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525, OEMR R660, OEMR XL R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR XL R760, OEMR R760xs, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR T140, OEMR T150, OEMR T340, OEMR T350, OEMR T360, OEMR T440, OEMR T550, OEMR T560, OEMR T640, OEMR XL T640, OEMR XL R240, OEMR XL R340, OEMR XL R660xs, OEMR XL R6615, OEMR XL R6625, OEMR XL R760xs, OEMR XL R7615, OEMR XL R7625, OEMR XR11, OEMR XR12, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XE2420, PowerEdge XE7100, PowerEdge XE7420, PowerEdge XE7440, PowerEdge XE8545, PowerEdge XE8640, PowerEdge XE9640, PowerEdge XE9680, PowerEdge XE9680L, PowerEdge XR11, PowerEdge XR12 ...
Propriedades do artigo
Número do artigo: 000193542
Tipo de artigo: Solution
Último modificado: 29 abr. 2025
Versão:  6
Encontre as respostas de outros usuários da Dell para suas perguntas.
Serviços de suporte
Verifique se o dispositivo está coberto pelos serviços de suporte.