PowerScale: Problémy s NANON CloudPools
Resumo: CloudPools vyžaduje, aby se každý uzel v clusteru mohl připojit k CloudPools, aby správně fungoval. Občasné problémy se mohou objevit, když se ani jediný uzel nemůže připojit k CloudPools. ...
Sintomas
Příznaky, které indikují potenciální situaci, kdy se ne všechny uzly můžou připojit k poskytovateli cloudu nebo cloudovému kbelíku:
- Pokud uzel není součástí síťového fondu, zobrazí se chyby při načítání souborů. To může být občasné nebo zdánlivě náhodné.
- Pokud je uzel součástí clusteru, který je cílem SyncIQ (SIQ), dojde k vstupně-výstupním chybám, které způsobí selhání úloh. Můžete vidět úspěšné úlohy nebo úlohy pouze s několika problematickými zásadami, ale to nedokazuje, že konfigurace funguje nebo že nedošlo k selhání.
- Při navracení souborů může docházet ke zpoždění.
- Při odvolání souborů může dojít k náhodným selháním a následné pokusy o načtení budou úspěšné.
Causa
CloudPools vyžaduje, aby každý uzel měl externí síťové připojení schopné přenášet data mezi systémem PowerScale a zařízením poskytovatele cloudu.
CloudPools používá síťový fond s nejnižší prioritou, který se může připojit. Pokud se připojit nemůže, posune se v seznamu síťových fondů dolů, dokud nenajde ten, který proběhne úspěšně, nebo zobrazí chybu, že se nemůže připojit.
Všechny uzly se účastní aktivity CloudPools. To je navrženo tak, aby bylo možné data co nejrychleji vyvolat nebo přesměrovat.
Neexistuje způsob, jak toto chování změnit.
Resolução
I když se můžete pokusit o přístup kladiva, jako je restartování úlohy SyncIQ pokaždé, když selže, není to dlouhodobé řešení.
Jediným řešením je ověřit, že se každý uzel může připojit k vašemu cloudovému kbelíku.