Data Domain - Problemas do BoostFS com software ou aplicativos de scanner de segurança

Resumo: O Boostfs no client Linux e Windows se comporta inesperadamente quando o Security Scanner ou os aplicativos de segurança verificam ou acessam arquivos dentro de um ponto de montagem do Boostfs. ...

Este artigo aplica-se a Este artigo não se aplica a Este artigo não está vinculado a nenhum produto específico. Nem todas as versões do produto estão identificadas neste artigo.

Sintomas

A unidade montada ou o ponto de montagem do BoostFS não responde.

As operações de backup do aplicativo podem falhar com leituras e gravações malsucedida nos arquivos no ponto de montagem. Exemplo:
​​Apr 19 10:15:09.853 29214 2269886208 [E] [ddp log] [721E:7FC860125190] ddcl_ddcp_pwrite: Error in ddcl_ddcp_pwrite. [ERR=5002]
Apr 19 10:15:13.990 29214 2269886208 [E] [ddp log] [721E:7FC860125190] ddcl_ddcp_pwrite: Error in ddcl_ddcp_pwrite. [ERR=5002]
 
O Boostfs parece ter desconexões frequentes e erros de repetição.
Feb 24 19:52:46.803 423080 2833229568 [I] bfs_node_lookup: failed to obtain a connection; file=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2
Feb 24 19:52:46.803 423080 2833229568 [E] bfs_node_retry_conn: lookup failed path=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2
Feb 24 19:52:46.803 423080 2833229568 [E] bfs_open: lookup failed file=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2
Feb 24 19:52:46.803 423080 2833229568 [P] BFSPROC_EXIT_bfs_open: rc=-11

Degradação do desempenho. As operações de leitura ou gravação (backup ou restauração) tornam-se lentas.

Causa

  • O software ou aplicativos de scanner de segurança instalados na máquina verifica o ponto de montagem do Boostfs, juntamente com outras unidades e pastas
  • O BoostFS não recomenda vários aplicativos, inclusive os scanners de segurança, para acessar o ponto de montagem do BoostFS simultaneamente.
  • Isso pode resultar em falha, dependendo da natureza do acesso, pois temos um contexto de arquivo único mantido no BoostFS.
  • Além disso, o software antivírus/de scanner de segurança pode impedir algumas operações específicas do file system.

Triaging: verifique

as "informações do aplicativo" nas mensagens de registro do Boostfs. Isso seria preenchido com os nomes de software antivírus/security scanner. Aqui "s1-agent" e "s1-fanotify" são os nomes dos aplicativos de scanner de segurança
ddboostfs_0_0.log:265760:Apr 21 16:51:09.048 26822 1603430144 [D] bfs_get_app_info: app_info=s1-agent
ddboostfs_0_0.log:266094:Apr 21 16:51:10.102 26822 1603430144 [D] set_conn_app_info: app_info=s1-agent
Feb 24 19:52:46.803 423080 2394937088 [D] bfs_get_app_info: app_info=s1-fanotify
Isso significa que o software do scanner está acessando o ponto de montagem do Boostfs.

Verifique o aplicativo nas conexões do DDBOOST detalhadas no DD ASUPs
DDBOOST Connections Detailed with-fips-mode
----------------------------Active Clients: 5Clients:
Client                             Idle   CPUs   Memory(MiB)    Plugin Version                                                 OS Version                                Application Version   Encrypted   DSP   Transport     FIPS mode
--------------------------------   ----   ----   -----------   ---------------   --------------------------------------------------------   ------------------------------------------------   ---------   ---   ---------   -----------

c3po01                    YES      14        64,152   7.7.4.0-1017373                 Linux 4.1.12-124.67.3.el7uek.x86_64 x86_64        BOOSTFS:7.7.4.0-1017610 FUSE:2.9.4 s1-agent          NO   YES        IPv4            NO

Por fim, verifique as configurações dos aplicativos scanner se eles incluem os pontos de montagem/unidades montadas do Boostfs.

Resolução

É recomendável executar verificações antivírus fora da janela de operações do Boostfs.

Verifique se as configurações do aplicativo Security Scanner podem ser modificadas para excluir os pontos de montagem do Boostfs da digitalização e quaisquer outras operações realizadas por ele.

Mais informações

  1. Este artigo se aplica a todas as versões do BoostFS, independentemente de qualquer software de scanner de segurança instalado nele.
  2. Os problemas relatados são referentes a vários scanners de segurança, inclusive Carbon-Black, McAfee, Fanotify, s1-agent, CrowdStrike e muito mais.

Produtos afetados

Data Domain
Propriedades do artigo
Número do artigo: 000215701
Tipo de artigo: Solution
Último modificado: 26 jan. 2024
Versão:  4
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