Data Protection Advisor (DPA): O agente DPA apresentou falha ao registrar-se no Application Server com erro exception.name_conflict
Resumo: O agente DPA não se registra no Application Server com erro exception.name_conflict
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Sintomas
A nova instalação do agente DPA não foi registrada no servidor de aplicativos do DPA. Dentro do dpaagent. log, o seguinte erro indica que o registro falha devido a conflito de nomes:
No entanto, o erro acima não fornece o nome do conflito exato, mesmo com o nível baixo de depuração de agente ativado.
< erro >
ID de < > Exception.name_conflict </id >
< mensagem > um alias com o mesmo nome já existe. Escolha outro nome </Message >
< entry Name = "Type" > alias </entry >
</Error >
Err 18330,18330 20210304:210609 Agent. config-initAgentConfig (): Failed to register agent with the server. Aguardando para repetir...
ID de < > Exception.name_conflict </id >
< mensagem > um alias com o mesmo nome já existe. Escolha outro nome </Message >
< entry Name = "Type" > alias </entry >
</Error >
Err 18330,18330 20210304:210609 Agent. config-initAgentConfig (): Failed to register agent with the server. Aguardando para repetir...
No entanto, o erro acima não fornece o nome do conflito exato, mesmo com o nível baixo de depuração de agente ativado.
Causa
A falha de registro do agente é causada por conflitos de nome como visto no registro do dpaagent. Uma vez que o hostname que está causando o conflito for removido, o agente será capaz de registrar-se com sucesso com o servidor de aplicativos do DPA.
Resolução
O nome do conflito não foi encontrado no registro de dpaagent, mesmo com o nível baixo de depuração ativado, pois o servidor de aplicativos do DPA rastreia essas informações. Para determinar o nome do conflito e resolver o problema, siga as etapas abaixo:
Entre em contato com a equipe de suporte técnico da Dell EMC para obter mais detalhes ou informações.
- Acesse o servidor de aplicativos do DPA e navegue até o servidor. log em < o diretório de instalação do DPA >/Services/logs/.
- No Server. log, pesquise por palavra-chave "nó já encontrado". Algo semelhante ao seguinte deve ser visto:
2021-03-05 09:54:53114 ERROR [com. EMC. Apollo. Command. Node. UpdateNodeCommandBean] (http-/0.0.0.0:9002-3) nó já encontrado usando um novo alias XXXXXX nome do nóelement existente: A
09:54:53114 Error [org. JBoss. as. EJB3] (http-/0.0.0.0:9002-3) javax. ejb. EJBTransactionRolledbackException: Já existe um alias com o mesmo nome. Escolha outro nome (exception.name_conflict)
09:54:53114 Error [org. JBoss. as. EJB3] (http-/0.0.0.0:9002-3) javax. ejb. EJBTransactionRolledbackException: Já existe um alias com o mesmo nome. Escolha outro nome (exception.name_conflict)
- Vá para o DPA GUI > inventário > Biblioteca de objetos > guia hosts e pesquise por host a.
- Selecione o host a a seção Propriedades > aliases e procure o nome do conflito XXXXXX.
- Crie uma cópia de todos os nomes de alias caso haja um problema.
- Selecione alias name XXXXXX e clique em Delete.
- Clique em Aplicar e, em seguida OK.
- Reinicie o agente DPA que apresentou falha no registro e ele deve ser capaz de registrar-se no servidor de aplicativos do DPA.
Entre em contato com a equipe de suporte técnico da Dell EMC para obter mais detalhes ou informações.
Produtos afetados
Data Protection AdvisorPropriedades do artigo
Número do artigo: 000183846
Tipo de artigo: Solution
Último modificado: 23 jul. 2021
Versão: 4
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