AppSync: Error "Requested Task Failed Invalid configuration for device '0'" seen when unmounting Virtual Disks
Summary: Users may experience intermittent errors when unmounting copies that contain VMware Virtual disks.
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
The following error may be seen when unmounting previous copies:
2021-10-14 02:17:16.787,Unmount previous copy,44dfc111-8a49-46b9-b905-ceb5f7111128,VM_000077,<APPSYNC SERVER>,Virtual center service operation failed with error: Requested Task Failed Invalid configuration for device '0'.. Using the VI client, check the ESX servers for tasks and events, or alarms.
Cause
VMware does not support removing Virtual Disks from a Virtual Machine where a VMware snapshot of the Virtual Disk exists. This is expected behavior for VMware and is described in the following VMware article:
These Virtual Disk snapshots are created by a user or by an application such as Avamar. Once created, a snapshot prevents AppSync from being able to unmount the Virtual Disk from the VM. This prevents the removal of the datastore and array snapshot that contains the target Virtual Disk.
Resolution
There are three possible options to address this issue.
- Virtual disks mounted with the "Independent" option either Persistent or Non-Persistent, prevent VMware from making a snapshot of them as part of the snapshot of the Virtual Machine. When configuring AppSync to mount a copy, enable the VMware Virtual Disk Mode option. Persistent (default) or Non-Persistent may be chosen while configuring this option but both prevents VMware from making a snapshot of the Virtual Disk.
- Using the VMware UI, manually reintegrate any VMware snapshots of the Virtual Machine before attempting to unmount an AppSync copy.
- Schedule operations that may create a VMware snapshot for times when AppSync is not performing Mount or Unmount operations to the target VM.
Produse afectate
AppSyncProduse
AvamarProprietăți articol
Article Number: 000193274
Article Type: Solution
Ultima modificare: 12 mai 2026
Version: 4
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.