Data Protection Advisor: Agent fails to register with "HTTP response code is 403" error
Zhrnutie: Data Protection Advisor agent on Windows fails to register with the application server due to error HTTP response code is 403
Tento článok sa vzťahuje na
Tento článok sa nevzťahuje na
Tento článok nie je viazaný na žiadny konkrétny produkt.
V tomto článku nie sú uvedené všetky verzie produktov.
Symptómy
The agent fails to register with the DPA application server even after confirming correct agent password. Put the agent into Debug Low by modifying the config file.
- Stop the agent.
- Make a copy of the dpaagent_config.xml
(<install dir>\emc\dpa\agent\etc\dpaagent_config.xml)
- Edit dpaagent_config.xml and set the Logging Level from "Info" to "Debug Low":
<LOGLEVEL>Debug Low</LOGLEVEL>
- Save the file.
- Start the agent.
The following is observed in the agent log:
DBG2 6836.7608 20210310:140114 agent.config - registerAgentProcess(): HTTP response code is 403
ERR 6836.7608 20210310:140114 agent.config - registerAgentProcess(): No response data
ERR 6836.7608 20210310:140114 agent.config - initAgentConfig(): Failed to register agent
ERR 6836.7608 20210310:140114 agent.config - registerAgentProcess(): No response data
ERR 6836.7608 20210310:140114 agent.config - initAgentConfig(): Failed to register agent
Príčina
The HTTP 403 Forbidden client error status response code indicates that the server understood the request but refuses to authorize it.
There is an Internet proxy configured in the Windows OS.
On the host, run the following command to confirm if a proxy is configured:
c:\> netsh winhttp show proxy
Current WinHTTP proxy settings:
Proxy Server(s) : proxy.customerdomain.com:8080
There is an Internet proxy configured in the Windows OS.
On the host, run the following command to confirm if a proxy is configured:
c:\> netsh winhttp show proxy
Current WinHTTP proxy settings:
Proxy Server(s) : proxy.customerdomain.com:8080
Riešenie
- Remove the proxy configuration:
c:\> netsh winhttp reset proxy
- Restart the DPA agent.
- Confirm the agent has registered by checking the dpaagent.log:
INFO 6836.7608 20210310:150114 agent.config - initAgentConfig(): Agent has successfully registered with the server
It should now be visible on the GUI under Data Collection > Agents.
Remember to set the agent logging level back to Info.
Contact Dell Technical Support for further information.
Dotknuté produkty
Data Protection, Data Protection Suite, Data Protection AdvisorVlastnosti článku
Číslo článku: 000184051
Typ článku: Solution
Dátum poslednej úpravy: 10 sep 2025
Verzia: 5
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.