Avamar: Administrator UI reports an incorrect Data Domain status due to SNMP configuration issues
摘要: Simple Network Management Protocol (SNMP) configuration issues can cause on Avamar/Data Domain integration.
症状
Avamar monitoring status for Data Domain changes to Yellow or Red from Green on the Avamar Administrator UI.
- Error: Unable to get SNMP file system status
- Error: Unable to get file system information
- Error: Unable to get disk status
- Error: Unable to retrieve ssh keys
原因
If SNMP is not configured correctly on the Data Domain this results in SNMP errors on the Avamar Administrator UI.
解决方案
Verify that SNMP is configured correctly on the Data Domain:
1. Log in to the Avamar Utility Node and load the keys: Avamar: How to Log in to an Avamar Server and Load Various Keys.
2. Access the Data Domain server in Admin or System Engineer (SE) mode: How To Access a Data Domain System from an Avamar Server
3. Check the SNMP configuration:
snmp show config
General Configuration
---------------------
SNMP sysLocation:
SNMP sysContact: SNMPsyscontact@mail.com
SNMP v2c Configuration
---------------------
Community Access Host
---------- --------- -----
public1 read-only *
public11 read-only *
publicuser read-only *
test read-only *
---------- --------- -----
Trap Host Port Community
-------------------- ---- ---------
examplehost 163
examplehost2 163
137.xx.xx.xxx 163
AvamarTest 163
10.xx.xx.xx 163 test
-------------------- ---- ---------
SNMP v3 Configuration
---------------------
User Access Authentication Protocol Privacy Protocol
---- ------ ----------------------- ----------------
---- ------ ----------------------- ----------------
Trap Host Port User
--------- ---- ----
--------- ---- ----
- The community string on the Data Domain (that Avamar uses) is recommended to be a read-only community string
- The community string on the Data Domain (that Avamar uses) should be associated with the Avamar hostname or the wildcard "*"
4. Check that the SNMP trapd service is enabled on the Data Domain:
snmp trapd status
Output:
SNMP Trapd is enabled.
-- Or --
SNMP Trapd is disabled.
If it is disabled: Use the following command to re-enable it:
trapd service.
See Data Domain: The importance of keeping SNMP trapd disabled
snmp trapd enable
Confirm the status to verify it is now enabled:
snmp trapd status
5. Restart the SNMP service for Data Domain on Avamar after making the SNMP configuration changes.
This can be done using the following steps.
a. Return to the Avamar Utility Node.
b. Switch to root privilege.
c. Restart the SNMP service:
mcddrsnmp restart
d. Allow the SNMP service approximately 3-5 minutes to update the status on the UI after running the command.
6. If the issue is still not resolved, review the resolution path for SNMP issues per Avamar: Troubleshooting Data Domain Integration Reporting Errors in the Avamar Administrator UI (Resolution Path).
其他信息
Reference Material: