PowerScale: Isilon: Brug af sudo-konto efter opgradering mislykkes med "USER er ikke i sudoers-filen. Denne hændelse er rapporteret." (Kan rettes af brugeren)

摘要: Sudo-konti i et begrænset antal OneFS-versioner blev oprettet ved hjælp af en løsning. Når klyngen opgraderes til en OneFS-kodeversion, hvor problemet blev løst, fungerer disse sudo-konti ikke korrekt. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Koden blev opgraderet fra en version af OneFS, hvor isi_visudo ikke arbejdede på en nyere version af OneFS, hvor isi_visudo blev rettet.

sudo konti, der er oprettet på en OneFS-version med en defekt isi_visudo Oplevede fejl med sudo efter opgradering til en korrekt kodeversion (f.eks. v8.1.0.4). Trods sudo kontoposteringer, der bekræftes i /etc/mcp/override/sudoers og /usr/local/etc/sudoers—som kræver root adgang—sudo fungerede ikke korrekt.

Mere output fra den ikke-fungerende sudo-konto kan se ud som følgende output ud over USERNAME is not in the sudoers file fejl:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

原因

Problemet er relateret til OneFS-koden.

解决方案

Log på som ikonet root bruger, og:

  1. Brug
    isi_visudo
    og slet den USER-konto, der blev konfigureret til sudo. Vær forsigtig med kun at slette sudo konto, der ikke fungerer. Gem filen. 
    :wq!
  2. Brug
    isi_visudo
    og genoprette USER-kontoen med de korrekte indstillinger. Gem filen.

Kodeopgraderingen bør ikke påvirke rollerne og andre godkendelser. Brugerkontoen og adgangskoden forbliver uændrede. Når du har udført ovenstående trin, fungerer kontoen igen.

受影响的产品

Isilon

产品

Isilon, PowerScale OneFS
文章属性
文章编号: 000059475
文章类型: Solution
上次修改时间: 01 4月 2025
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。