NetWorker: NMC:hen kirjautuminen ei onnistu AD-/LDAP-tilillä Unable to login, verify that the authentication service on [servername] is running

摘要: NMC:hen kirjautuminen ei onnistu päivityksen jälkeen, kirjautuminen ei onnistu-virhe, varmista, että [servername]-todennuspalvelu on käynnissä

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Kun kirjaudut NMC (NetWorker Management Console) -konsoliin AD-/LDAP-tilillä, näyttöön tulee seuraava virheilmoitus: "Unable to login, verify that the authentication service on [servername] is running"

The NMC server's gstd.raw may report:
servername.domain gstd NSR error 78 Unable to login, verify that the authentication service on %s is running: [%s] 2 0 21 servername.domain 0 37 Authentication service is unavailable

原因

AD-/LDAP-määritys on tehty käyttämällä SSL-varmenteita (LDAPS). Nämä varmenteet tuotiin NetWorker-palvelin java-instanssin cacerts-avaintoreen. Authc ei käytä varmenteita.

解决方案

Tarkat ohjeet LDAPS:n määrittämiseen NetWorkerilla ovat artikkelissa https://www.dell.com/support/kbdoc/000156132/
Tiedot LDAPS:n määrittämisestä löytyvät NetWorker Security Configuration -oppaasta seuraavasti: https://www.dell.com/support/

Varmenteiden prosessi on seuraava:
  1. Hae pää- ja ketjuvarmenteet LDAP-palvelimesta:
avaa s_client -showcerts -connect LDAP_server_name:636
 
Huomautus: Joissakin ympäristöissä vain yksi varmenne palautetaan. Jos kuitenkin useita (ketju) varmenteita palautetaan, luo yksittäinen .cer-varmenne, joka sisältää yksittäiset varmennetulokset. Varmenteet sisältävät ---BEGIN-VARMENTEEN--- ja ---END CERTIFICATE--- -rivit.
 
  1. Tarkista, onko avaintoressa varmenteen varmenteen nykyisiä varmenteita: 
    /opt/nre/java/latest/bin/keytool -list -keystore /opt/nre/java/latest/lib/security/cacerts -storepass changeit | grep -i LDAP_server_name
a. Jos LDAP-palvelimen avainsäilössä näkyy varmenteen aliaksia, poista ne seuraavasti: 
/opt/nre/java/latest/bin/keytool -delete -alias ALIAS_NAME -keystore /opt/nre/java/latest/lib/security/cacerts -storepass changeit

 
  1. Lisää uudet ketjut ja päävarmenteet (tässä järjestyksessä) Cacerts-tiedostoon...
# /opt/nre/java/latest/bin/keytool -import -alias LDAP_server_name_CHAIN -keystore /opt/nre/java/latest/lib/security/cacerts -file /tmp/chain.cer -storepass changeit # /opt/nre/java/latest/bin/keytool -import -alias LDAP_server_name_ROOT -keystore /opt/nre/java/latest/lib/security/cacerts -file /tmp/root.cer -storepass changeit # /opt/nre/java/latest/bin/keytool -list -keystore /opt/nre/java/latest/lib/security/cacerts | grep -i LDAP_server_name anna avainsalasana:  changeit LDAP_server_name_ROOT, 13.10.2021, trustedCertEntry, LDAP_server_name_CHAIN, 13.10.2021, trustedCertEntry,
 
  1. Käynnistä NetWorker uudelleen:
 
 
systemctl-aloitusverkon nsr_shutdown
 
  1. suorita authc_config uudelleen
 
# /opt/nsr/authc-server/bin/authc_config -u Administrator -e update-config -D config-id=2 -D config-active-directory=y -D config-user-dn-password=<PASSWORD FOR USER> anna salasana: <Networker ADMINISTRATOR Password> Configuration SLDAP -päivitys onnistuu.


 
 

其他信息

受影响的产品

NetWorker, NetWorker Management Console
文章属性
文章编号: 000192505
文章类型: Solution
上次修改时间: 10 1月 2022
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。