CloudLink: Poista käytöstä AWS-konsolin yhteys CloudLink-käyttöjärjestelmään

摘要: AWS:llä on esiasennettu SSM-agentti kaikissa tuetuissa käyttöjärjestelmissä. Tämä SSM-agentti antaa myös pääsyn suoraan CloudLink-käyttöjärjestelmän konsoliin.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Dell suosittelee, että SSM-agentti poistetaan CloudLink-esiintymistä, koska se aiheuttaa tietoturvahaavoittuvuuksia.

原因

AWS:ssä SSM-agentti on esiasennettuna kaikissa tuetuissa käyttöjärjestelmissä, jotta käyttöjärjestelmäkonsoli voidaan avata suoraan.

Tuotteet ja versiot, joita ongelma koskee: Kaikki CloudLink-versiot versioon 7.1.3 saakka, kun ne otetaan käyttöön AWS:ssä.

解决方案

Jotta kirjautuminen voidaan poistaa käytöstä Session Managerin kautta CloudLink-käyttöjärjestelmään, järjestelmänvalvojan on poistettava SSM-agentti CloudLink-esiintymästä.

Kiertotapoja on kaksi:
Remediation workflow 1:   Kun käyttäjä voi käyttää CloudLink-konsolia Session Managerin kautta,
Korjaustyönkulku 2:   Kun käyttäjä ei voi käyttää CloudLink-konsolia Session Managerin kautta,


Korjaustyönkulku 1:

1.    CloudLink-esiintymä.
image.png

2.    Valitse Session Manager -välilehdessä -> Connect (Yhdistä) -painike
image.png

3.    Kun olet CloudLink-konsolissa Session Managerilla, kirjoita sudo su
image.png

4.    Tarkista CloudLink-konsolissa käynnissä olevan SSM-agentin tila komennolla
systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"

image.png
5.    Voit näyttää käynnissä olevan SSM-agentin CloudLink-konsolissa komennolla
snap list amazon-ssm-agent"
image.png

6.    Poista SSM-agentti CloudLink-konsolista komennolla
snap remove amazon-ssm-agent Validate

image.png SSM agent is removed from CloudLink instance.

7.    Kun SSM-agentin CloudLink-esiintymän asennus poistetaan, Connect-painike poistetaan käytöstä
image.png
8.    Kun käyttäjä yrittää SSH:n ja CloudLinkin IP-osoitetta, käyttäjä siirtyy CloudLink-kirjautumiskehotteeseen
image.png

9.    Tarkista SSM-agentin tila.  Varmista, että agentti on "Pysähtynyt"
image.png

10.    Tarkista SSM-agenttien luettelo.  Tilailmoitus No matching snaps installed.
image.png

Korjaustyönkulku 2:
Session Manager ei ole käytössä, kun IAM-roolia ei ole valittu. Ilman Istunnon hallintaa käyttäjä ei voi käyttää CloudLink-konsolia.
Voit tarkistaa IAM-profiilin kirjautumalla AWS-> Launch EC2 -instance -> Advanced details -> IAM Instance profile
image.png
Recommended not select any profile under "IAM Instance profile", mikä estää Session Manageria muodostamasta yhteyttä CloudLink-konsoliin.
image.png

HUOMAUTUS: Jos Session Manager ei voi muodostaa yhteyttä CloudLink-konsoliin, käyttäjän on otettava yhteys tekniseen tukeen , jotta SSM-agentin asennus voidaan poistaa CloudLink-esiintymistä.

受影响的产品

CloudLink SecureVM, CloudLink
文章属性
文章编号: 000200819
文章类型: Solution
上次修改时间: 09 11月 2022
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。