CloudLink: Aws-consoletoegang tot CloudLink OS uitschakelen

摘要: AWS heeft vooraf geïnstalleerde SSM-agent op alle ondersteunde besturingssystemen. Deze SSM-agent geeft ook rechtstreeks toegang tot de CloudLink OS-console.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Dell raadt aan om de SSM-agent uit CloudLink-instanties te verwijderen, omdat dit leidt tot beveiligingslekken.

原因

In AWS is de SSM-agent vooraf geïnstalleerd op alle ondersteunde besturingssystemen om rechtstreeks toegang tot de console van het besturingssysteem toe te staan.

Van toepassing op producten en versies: Alle versies van CloudLink tot 7.1.3 wanneer geïmplementeerd in AWS.

解决方案

Om aanmelding via Session Manager naar CloudLink OS uit te schakelen, moet de Administrator de SSM-agent uit de CloudLink-instantie verwijderen.

Er zijn twee tijdelijke oplossingen:
herstelworkflow 1:   Wanneer de gebruiker toegang heeft tot de CloudLink-console via Session Manager.
Herstelworkflow 2:   Wanneer de gebruiker geen toegang heeft tot de CloudLink-console via Session Manager.


Herstelworkflow 1:

1.    Exemplaar van CloudLink.
image.png

2.    Klik op het tabblad Session Manager -> klik op Connect knop
image.png

3.    Zodra u in de CloudLink-console bent met Session Manager, voert u sudo su
image.png

4 in.    Om de status van de SSM-agent te controleren die wordt uitgevoerd op de CloudLink-console, voert u de onderstaande opdracht
"systemctl status snap.amazon-ssm-agent.amazon-ssm-agent.service"

image.png
5 uit.    Voer de onderstaande opdracht
"snap list amazon-ssm-agent"

image.png
6 uit om de actieve SSM-agent op de CloudLink-console weer te geven.    Om de SSM-agent uit de CloudLink-console te verwijderen, voert u de onderstaande opdracht
"snap remove amazon-ssm-agent"

image.pngValidate SSM agent is removed from CloudLink instance uit.

7.    Wanneer de SSM-agent cloudlink-instantie wordt verwijderd, wordt de knop 'verbinden' uitgeschakeld
image.png
8.    Wanneer de gebruiker probeert om naar het CloudLink IP-adres te SSH te gaan, gaat de gebruiker naar CloudLink-aanmeldingsprompt
image.png

9.    Controleer op de status van de SSM-agent.  Controleer of de agent is 'Gestopt'10

image.png
.    Controleer de lijst met SSM-agents.  Status retourneren "No matching snaps installed".
image.png

Herstelworkflow 2:
Session Manager is niet ingeschakeld wanneer er geen IAM-rol is geselecteerd. Zonder de aanwezigheid van Session Manager kan de gebruiker dus geen toegang krijgen tot de CloudLink-console.
Als u het IAM-profiel wilt controleren, meldt u zich aan bij AWS -> Launch EC2 instance -> Advanced details -> IAM Instance profile
image.png
Aanbevolen om geen profiel te selecteren onder 'IAM Instance profile'. Dit leidt ertoe dat Session Manager geen verbinding kan maken met de CloudLink-console.
image.png

OPMERKING: Op dit punt wanneer Session Manager geen verbinding kan maken met de CloudLink-console, moet de gebruiker contact opnemen met Technische Support om te helpen bij het verwijderen van de SSM-agent uit CloudLink-instanties.

受影响的产品

CloudLink SecureVM, CloudLink
文章属性
文章编号: 000200819
文章类型: Solution
上次修改时间: 09 11月 2022
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。