PowerStore: Nutzer kann keinen neuen NAS-Server in PowerStore Manager verschieben oder erstellen

摘要: Die Schaltflächen "Diesen bestimmten NAS-Server verschieben" und "NAS-Server erstellen" sind in PowerStore Manager aufgrund nicht gelöschter Warnmeldungen nach SDNAS-Docker-Fehler oder SDNAS-HA-Ereignis nicht verfügbar. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Nach einem Fehler in SDNAS werden die nas_server_down Warnmeldungen möglicherweise einige Stunden lang nicht gelöscht. Die Option "Move NAS Server" ist in PowerStore Manager ausgegraut, bis das Löschereignis verarbeitet wurde.
Option

 

Hinweis: Die REST API kann weiterhin verwendet werden, um den NAS-Server zu verschieben.

 

原因

SDNAS-Fehler erzeugt mehrere SDNAS-Ereignisse. Aufgrund dieses plötzlichen Anstiegs von SDNAS-Ereignissen, insbesondere während eines Panikszenarios, ist CP Event Framework nicht in der Lage, die Ereignisse sofort zu verarbeiten.
Die Ereignisse werden in die Warteschlange gestellt, was zu einer Verzögerung im CP-Ereignis-Framework-Prozess führen kann.
Da es viele REST-API-Anforderungen in Bezug auf local_appliance_information vom Adapter gibt, um zu überprüfen, ob CP für die Änderung von Objektvorgängen aktiv ist oder nicht, verlangsamt diese kontinuierliche Anforderung vom Adapter den Ereignisschleifenthread.
Infolgedessen werden die Schaltflächen "Move that particular NAS Server" und "Create NAS Server" im PowerStore Manager deaktiviert.

 

解决方案

Dies ist ein automatisch gelöstes Problem, das innerhalb weniger Stunden behoben wird.

In der Zwischenzeit kann der Nutzer die REST API verwenden, um den NAS-Server zu verschieben.

 

其他信息

受影响的产品

PowerStore
文章属性
文章编号: 000224701
文章类型: Solution
上次修改时间: 07 6月 2024
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。