PowerStore: User unable to move or create a new NAS Server in PowerStore Manager

摘要: "Move that particular NAS Server" and "Create NAS Server" buttons are unavailable in PowerStore Manager as a result of uncleared alerts after SDNAS-Docker panic or SDNAS HA event.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

After a panic in SDNAS, the nas_server_down alerts may not get cleared for a couple of hours. The "Move NAS Server" option is grayed out in the PowerStore Manager until the clear event is processed.
Move NAS Server option is grayed out

 

Note: Rest API can still be used to move the NAS-Server.

 

原因

SDNAS panic generates multiple SDNAS-events. Due to this sudden increase of SDNAS-events, especially during a panic scenario, CP Event Framework is not able to process the events immediately.
The events are getting queued up, which may cause a delay in the CP Event Framework process.
As there are many REST-API requests, regarding local_appliance_information, from the adapter to check whether CP is up or not for modifying operations of objects, this continuous request from the adapter slows down the event-loop thread.
As a result, "Move that particular NAS Server" and "Create NAS Server" buttons are disabled from the PowerStore Manager.

 

解决方案

This is an auto-resolved issue which is resolved within a few hours.

In the meantime, user can use the Rest API to move NAS-Server.

 

其他信息

受影响的产品

PowerStore
文章属性
文章编号: 000224701
文章类型: Solution
上次修改时间: 07 6月 2024
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。