Güvenli Bağlantı Ağ Geçidi: HTTP proxy kimlik bilgilerini değiştirmek, SRS 3.52'den yükseltilen ağ geçitlerinde etkili değildir

摘要: Bu makalede, HTTP proxy kimlik bilgilerini değiştirmenin SRS 3.52'den yükseltilen ağ geçitlerinde neden etkili olmadığı açıklanmaktadır.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

SRS 3.52'den SCG 5.20'ye (desteklenen tek geçiş yolu budur) geçiş yaptıktan sonra proxy kimlik bilgilerini değiştirmeye çalışmak, ağ geçidi ile Dell arasındaki bağlantı kaybına neden olur.

原因

Sorun yalnızca, SRS 3.x ten SCG 5.20 ye geçişin ardından proxy kimlik bilgileri güncelleştirildiğinde görülür. Mosquitto.service'in, LockBox'ta depolanan kimlik bilgileri yerine mosquito.conf dosyasında yapılandırılan parolayı aldığı görüldü. Güncellenen kimlik bilgilerinin Lockbox'ta saklandığı gözlemlendi, ancak mosquitto.conf güncellenmedi. Parolanın önceliği mosquito.conf dosyası olduğundan, eski kimlik bilgileri kullanılıyordu.

解决方案

SCG ağ geçidini 5.20'den sonraki bir sürüme yükseltin, böylece eski kimlik bilgileri mosquitto.conf dosyasından kaldırılır.

Alternatif olarak, ağ geçidinin v5.20 sürümünde kalması gerekiyorsa aşağıdaki adımları kullanın:
  • Bağlıyken SCG WebUI'dan yeni kimlik bilgilerini bir kez daha uygulayın.
  • SCG-VE'de SSH oturumu açın ve kök olarak oturum açın.
  • Şu komutu kullanarak SRS kapsayıcısına girin:
    docker exec -it esrsde-app bash
  • Aşağıdaki komutu kullanarak mosquitto.conf adresinden şifreyi yorumlayın
  • sed -i 's/proxy_password/#proxy_password/g' /etc/mosquitto/conf.d/mosquitto.conf
  • Mosquitto hizmetini yeniden başlatın:
    wd stop esrsmosquitto                                                                                                  
    wd start esrsmosquitto
  • Kapsayıcının oturumunu kapatma ve SSH oturumu:
    exit
    exit
  • Yukarıdaki adımlar uygulandıktan sonra, kimlik bilgileri Kasadan alınacaktır.

产品

Secure Connect Gateway, Secure Connect Gateway, Secure Connect Gateway - Virtual Edition
文章属性
文章编号: 000227392
文章类型: Solution
上次修改时间: 02 8月 2024
版本:  1
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。