Avamar – Säkerhetskopiering av en datauppsättning som innehåller många trasiga symboliska länkar löper långsamt

摘要: Avamar-säkerhetskopiering av datauppsättning som innehåller många trasiga symboliska länkar löper långsamt.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

En Avamar-säkerhetskopiering av en datauppsättning som innehåller många symboliska länkar körs långsamt.

Det finns många poster i säkerhetskopieringsloggen som visar att vi säkerhetskopierar symboliska länkar.

2014-10-21 21:26:35 avtar Info <16280>: Not traversing 'E:\folder\folder\

folder\folder\folder\folder\someotherfile.zip' since it's a 'REPARSE_USER_SYMLINK_FILE' and 'dereference' flag not specified

 

Loggningsposter visar att symboliska länkar kan ha skadats.

2014/10/21-15:50:34.96600 [avtar]  GetReparsePointInfo() 'E:\folder\folder\folder\folder\folder\folder\folder\folder\folder\file.exe' does not have a resolveable target

 

原因

Data fanns tidigare på en annan enhet som hade bytts ut och omkonfigurerats.

Säkerhetskopieringsdatauppsättningen innehöll en katalog som innehöll över en halv miljon symboliska länkar.
När avtar detekterar en länk som trasig rapporterar den "does not have a resolveable target".
I det här scenariot uppstod beteendet eftersom
enheten nyligen hade omkonfigurerats

Åtgärden att kontrollera en symbolisk länk och se att den är trasig innebär en lång fördröjning. Säkerhetskopieringen tog cirka 9 timmar längre än normalt vid försök att skanna dessa (en halv miljon) trasiga symlinks.

Det verkar ha inträffat även om säkerhetskopieringen inte konfigurerades med --avreference.
Avreferensflaggan instruerar avtar att säkerhetskopiera målet för en symbolisk länk.
 
 -dereference. 2014/10/21-15:50:15.90899 [avtar] --dereference NOT specified, not adding any Cross-Volume Symlinks to freeze volumes list.

解析度

Mappen som innehåller de trasiga symlinks (~0,6 miljoner) exkluderades från säkerhetskopieringen.  

Slutförandetiden minskades från 11 timmar till cirka 2 timmar.

受影響的產品

Avamar

產品

Avamar, Avamar Client
文章屬性
文章編號: 000041052
文章類型: Solution
上次修改時間: 26 3月 2024
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。