Avamar:容量故障診斷、問題及問題 - 所有容量 (解決方案路徑)

摘要: 本解決方案路徑文章可作為所有 Avamar 容量問題的起點。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

容量可以看作是用戶端資料的用戶端備份作業在伺服器上使用的數據或磁碟空間。

容量問題可能會阻止正常的伺服器功能添加新數據,或者有時允許清理和刪除舊數據。

 

您可以開啟服務要求,以解決各種容量問題,例如:
  • 訓練
  • 教育
  • 問題
  • 垃圾收集 (GC) 故障的問題
  • 作業系統 (OS) 容量問題
  • GSAN 容量問題
  • 中繼資料容量問題
  • Data Domain (DD) 整合容量問題

原因

在解決 Avamar 網格上的容量問題時,需要考慮幾個因素。處理容量問題時,最重要的區別在於確定這可能與哪種類型的容量問題相關。

此解決方案可協助您判斷所遇到的問題類型,以及解決問題的方法。

解析度

在您的環境中確認以下每個故障診斷步驟。每個步驟都提供說明或文檔連結,以消除可能的原因並根據需要採取糾正措施。這些步驟為最適當的順序,以隔離問題並找出適當的解決方法。請勿跳過步驟。如果容量以不同的方式發生多個問題,則必須按照特定的順序解決這些問題。

雖然大部分步驟僅提及 Avamar,但「Avamar - NetWorker」和「Avamar - Data Domain」整合仍會產生以下許多問題。

 

步驟 1:資訊收集:若要大致瞭解 Avamar 容量問題,「描繪一幅圖畫」就能看到整個問題和情況。有時,容量的一個方面可能會影響另一個方面,或者有些人最初可能沒有意識到存在多個問題。必須完全瞭解問題才能開始故障排除。

請參閱 Avamar:如何收集針對資訊收集容量問題進行故障診斷所需的資訊

 

步驟 2:教育與訓練:如果客戶正在尋找有關容量如何運作、某些值的含義等方面的培訓或理解,則可以使用本文。了解他們的問題並「描繪一幅畫」仍然是一個好主意,因為問題或教育往往是能力問題的結果。

請參閱 Avamar 容量一般訓練 - 教育解決路徑和訓練相關能力問題。

 

步驟 3:高作業系統容量: 從步驟 1 收集的輸出中,檢查作業系統容量值。作業系統容量會受到所有分割區中 「最高 」使用值的限制,即使其他容量較低亦會限制。最大值是“限制因素”,必須降低。

如果任何節點磁碟分割的最高使用率值超過 89%,請參閱 Avamar 作業系統容量 (解決方案路徑)

注意:如果一個資料節點上最高和最低磁碟分割值之間的差異為 20% 或更多,則亦適用 Avamar 作業系統容量 (解決方案路徑)。
 
 

步驟 4:垃圾收集錯誤或失敗:從收集的輸出中,如果 Avamar 垃圾收集工作輸出錯誤訊息,則必須先解決此問題,才能解決剩餘類型的容量問題。

針對此類型的問題,請參閱 Avamar - 故障診斷垃圾收集 (GC) 故障 (解決方案路徑)

 

步驟 5:高 GSAN 容量:  從收集的輸出中,如果沒有作業系統容量問題,且 GC 未顯示錯誤訊息,請檢閱 GSAN 容量值: 

從 status.dpn,值為 65% 表示網格已滿(也稱為“管理員”模式或只讀),沒有容量增長空間。

注意: GSAN 容量約為63%(由於稱為 disknormaldelta)
 

針對這些情況,請參閱 Avamar GSAN (或使用者)容量 (解決方案路徑)

 

步驟 6:中繼資料容量: 當 Data Domain 與 Avamar 整合時,系統會引入新的容量限制 - 中繼資料容量。中繼資料容量是 Avamar 本身的容量。

透過 Data Domain 整合,可以將資料導向並傳送至 Data Domain 進行儲存,但 Avamar 仍包含 Avamar 上備份檔案的中繼資料。Avamar 會以「中繼資料容量」追蹤此容量。

檢閱步驟 1-5 並解決任何容量相關問題後,請檢閱 Avamar 中繼資料容量解決方案路徑中的中繼資料容量解決方案。

 

步驟 7:高 Data Domain 容量:  當 Data Domain 與 Avamar 整合時,Data Domain 伺服器本身可以填滿其容量。

下列解決方案路徑文章:協助判斷:

  • Avamar 的哪些潛在問題可能會導致 Data Domain 容量增加或用盡
  • Data Domain 的一些特定問題
  • 如果由於與 Avamar 無關的原因導致 Data Domain 已滿。

在審查步驟 1-6 並解決任何容量相關問題後,請檢閱 Avamar 整合解決方案路徑中的 Data Domain 高容量

 
 

其他問題:這些仍可視為顧慮,或會影響容量的問題:

  • 複寫來源和目標容量不相符:使用 Avamar 或任何整合式產品複製資料時,複寫來源和複寫目標網格的容量預期會相符。
這確實屬於檢查 GSAN 兩個網格上的容量,但始終需要圍繞複製配置和工作狀態執行其他驗證,以防手頭有其他容量相關問題:Avamar:複寫配對顯示不同的容量用量層級。如何調查原因。 
 
  • 管理主控台伺服器 (MCS) 會報告 下列訊息:
2012/10/06-21:11:09.75264 {0.4} [manage:3070]  ERROR: <0001> diskinfo::update invalid disk space parameters dev=831 total=1906261MB avail=1675818MB reserved=223410MB maxmb=223978MB newavail=1675818MB reservedoverflow=1 availmboverflow=0 

這是 MC 使用者介面 (UI) 中關於等量容量的報告問題,僅與此處討論的其他容量主題有些模糊相關。除了在 UI 中看到訊息外,偵測不到任何影響。

您可以在此處找到其他詳細資訊:
 
  • 容量預測報告:

 


 

受影響的產品

Avamar, Avamar Server
文章屬性
文章編號: 000163006
文章類型: Solution
上次修改時間: 06 3月 2025
版本:  11
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。