NVP vProxy: El respaldo de VM falla con el mensaje "VDDK Error: 13: No tiene derechos de acceso a este archivo"

摘要: Los respaldos de máquinas virtuales (VM) de NetWorker VMware Protection (NVP) fallan para todas las VM de un único vCenter o host ESXi con el error "VDDK Error: 13: No tiene derechos de acceso a este archivo." cuando faltan los permisos necesarios para la cuenta de usuario de vCenter. ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

  • Está respaldando VM con el dispositivo vProxy de NetWorker VMware Protection (NVP).
  • Todos los respaldos de máquinas virtuales de adición en caliente fallan con el siguiente error:
Failed to backup virtual disk "Hard disk 1".  Failed to initialize Block Reader.  Failed to open source VMDK '[DATASTORE] UUID/VM_NAME.vmdk': VDDK Error: 13: You do not have access rights to this file.

 

原因

Faltan los permisos necesarios en la cuenta de vCenter utilizada para agregar vCenter a NetWorker. Por ejemplo, si ejecuta la utilidad ProxyHC , se informa:

INFO        Checking vCenter user permissions
INFO   -------> Using: DOMAIN\vCenter_User
INFO   -------> Found role ID: -########
ERROR  -------> Failed to validate privileges. Missing privileges:
['VirtualMachine.Provisioning.GetVmFiles']

解析度

  1. Descargue la utilidad ProxyHC y compruebe si faltan permisos: NVP-vProxy: Cómo usar la herramienta de evaluación del estado ProxyHC en el dispositivo vProxy

    ./ProxyHC perm
  2. El administrador de vCenter debe corregir cualquier problema de permisos que se informe.

NOTA: La cuenta de vCenter que utiliza NetWorker debe tener permisos asignados en el objeto vCenter (raíz). Asegúrese de que el usuario no pertenezca a ningún grupo que tenga permisos restringidos en otro objeto (de nivel inferior) en VMware (por ejemplo, el centro de datos). Esto puede provocar el problema descrito en NVP vProxy: La restauración de imagen falla "ServerFaultCode: El permiso para realizar esta operación fue denegado.".

其他資訊

受影響的產品

NetWorker

產品

NetWorker
文章屬性
文章編號: 000173900
文章類型: Solution
上次修改時間: 24 10月 2025
版本:  6
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。