NVP vProxy: Zálohování virtuálního počítače selže a zobrazí se chyba "VDDK: 13: Nemáte přístupová práva k tomuto souboru"

摘要: Zálohování virtuálního počítače (VM) NetWorker VMware Protection (NVP) se nezdaří pro všechny virtuální počítače pro jednoho hostitele vCenter nebo ESXi s chybou "VDDK Error: 13: You do not have access rights to this file.", když uživatelský účet vCenter postrádá požadovaná oprávnění. ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

  • Zálohujete virtuální počítače pomocí zařízení NetWorker VMware Protection (NVP) vProxy.
  • Všechny zálohy virtuálních počítačů za provozu selžou s následující chybou:
Failed to backup virtual disk "Hard disk 1".  Failed to initialize Block Reader.  Failed to open source VMDK '[DATASTORE] UUID/VM_NAME.vmdk': VDDK Error: 13: You do not have access rights to this file.

 

原因

V účtu vCenter použitém k přidání nástroje vCenter do platformy NetWorker chybí požadovaná oprávnění. Pokud například spustíte utilitu ProxyHC , nahlásí:

INFO        Checking vCenter user permissions
INFO   -------> Using: DOMAIN\vCenter_User
INFO   -------> Found role ID: -########
ERROR  -------> Failed to validate privileges. Missing privileges:
['VirtualMachine.Provisioning.GetVmFiles']

解析度

  1. Stáhněte si nástroj ProxyHC a zkontrolujte, zda chybí oprávnění: NVP – vProxy: Jak používat nástroj pro kontrolu stavu ProxyHC na zařízení vProxy

    ./ProxyHC perm
  2. Správce nástroje vCenter musí opravit všechny nahlášené problémy s oprávněními.

POZNÁMKA: Účet vCenter používaný nástrojem NetWorker musí mít přiřazená oprávnění k objektu vCenter (kořenový). Ujistěte se, že uživatel nepatří do žádné skupiny, která má omezená oprávnění k jinému objektu (nižší úrovně) v systému VMware (například k datovému centru). To může vést k problému popsanému v NVP vProxy: Obnovení bitové kopie selže "ServerFaultCode: Povolení k provedení této operace bylo odepřeno.".

其他資訊

受影響的產品

NetWorker

產品

NetWorker
文章屬性
文章編號: 000173900
文章類型: Solution
上次修改時間: 24 10月 2025
版本:  6
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。