NVP vProxy: O backup da VM falha com o erro "VDDK Error: 13: Você não tem direitos de acesso a este arquivo"

摘要: Os backups de máquina virtual (VM) do NetWorker VMware Protection (NVP) falham para todas as VMs de um único host do vCenter ou do ESXi com o erro "VDDK Error: 13: Você não tem direitos de acesso a esse arquivo." quando a conta de usuário do vCenter não tiver as permissões necessárias. ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

  • Você está fazendo backup de VMs com o equipamento vProxy NetWorker VMware Protection (NVP).
  • Todos os backups de VM Hot Add falham com o seguinte erro:
Failed to backup virtual disk "Hard disk 1".  Failed to initialize Block Reader.  Failed to open source VMDK '[DATASTORE] UUID/VM_NAME.vmdk': VDDK Error: 13: You do not have access rights to this file.

 

原因

A conta do vCenter usada para adicionar o vCenter ao NetWorker não tem as permissões necessárias. Por exemplo, se você executar o utilitário ProxyHC , ele relata:

INFO        Checking vCenter user permissions
INFO   -------> Using: DOMAIN\vCenter_User
INFO   -------> Found role ID: -########
ERROR  -------> Failed to validate privileges. Missing privileges:
['VirtualMachine.Provisioning.GetVmFiles']

解析度

  1. Faça download do utilitário ProxyHC e verifique se há permissões ausentes: NVP - vProxy: Como usar a ferramenta de verificação de integridade ProxyHC no equipamento vProxy

    ./ProxyHC perm
  2. O administrador do vCenter deve corrigir todos os problemas de permissão relatados.

Nota: A conta vCenter usada pelo NetWorker deve ter permissões atribuídas ao objeto vCenter (raiz). Certifique-se de que o usuário não pertença a nenhum grupo que tenha permissões restritas em outro objeto (nível inferior) no VMware (por exemplo, o Datacenter). Isso pode levar ao problema descrito no vProxy do NVP: A restauração da imagem apresenta falha "ServerFaultCode: A permissão para realizar essa operação foi negada.".

其他資訊

受影響的產品

NetWorker

產品

NetWorker
文章屬性
文章編號: 000173900
文章類型: Solution
上次修改時間: 24 10月 2025
版本:  6
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。