NetWorker: Creating a new client does not complete with message "is not a valid hostname as it cannot be resolved in DNS"

摘要: Adding a client through New Client Properties in NetWorker 19.7.0.3 does not complete, and reports an error "Name is not a valid hostname as it cannot be resolved in DNS. Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p FlushDnsCache)." ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Adding a client through New Client Properties in NetWorker 19.7.0.3 does not complete and displays the following error:
Name <CLIENTNAME> is not a valid host name as it cannot be resolved in DNS.
Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p <NetWorker server pid> FlushDnsCache).
 
Screenshot of Error message
Figure 1: Screenshot of Error message

原因

The hostname fails name resolution either through DNS or through the 'hosts' file.

Even if the hostname resolves, if this error message occurred previously, the NetWorker DNS Cache prevents the client from being added.

解析度

Add the client hostname to DNS (forward and reverse entries) or add it to the 'hosts' file using the format:

IP Address [space/tab] FQDN [space/tab] Short Name


Follow the steps below to "flush" the NetWorker DNS Cache:

  1. Obtain the PID of the 'nsrd' and 'nsrexecd' processes using the below commands:

Windows:

tasklist | findstr nsrd.exe
tasklist | findstr nsrexecd.exe

Linux:

ps -e | grep nsrd
ps -e | grep nsrexecd
  1. Run the below command against the PID of the 'nsrd' and 'nsrexecd' and use the switch as shown:
dbgcommand -p <PID> FlushDnsCache
文章屬性
文章編號: 000212659
文章類型: Solution
上次修改時間: 29 6月 2023
版本:  3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。