Домен даних: Монтування NFS: ls призводить до помилки: читання каталогу '.': Загальний дескриптор застарілого файлу 0

摘要: Редагувати монтування NFS: ls призводить до помилки: читання каталогу '.': Загальний дескриптор застарілого файлу 0 Однією з причин цієї помилки є непрацюючий символічний зв'язок з каталогом. ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Клієнти можуть успішно підключитися до експорту NFS (Приклад: /ddvar

Виконуємо команду: "ls" призводить до повідомлення message:
Застарілий дескриптор 

файла Клієнти можуть надсилати компакт-диски до каталогів у /ddvar/ , наприклад releases або log, а потім ls повертає результати. 
    "CD releases" або "CD log", тоді "ls" буде успішним.

原因

Однією з потенційних причин такої поведінки є непрацюючий символічний зв'язок.

解析度

Наведені нижче кроки допоможуть вам перевірити, чи пов'язана така поведінка з недійсним символічним зв'язком під час експорту NFS (Приклад: /ddvar)

1) Увійдіть в режим SE і запустіть ls до шляху експорту. Приклад:
ddvar #se ls -al /ddr/var/

ПРИМІТКА:  Ддвар - це особливий шлях. /ddvar внутрішньо перетворюється на /ddr/var і має використовуватися як /ddr/var при використанні внутрішніх команд.
2) Шукайте символічні посилання:  (Приклад нижче, зверніть увагу на символ «l» на крайньому лівому символі, а також на символ «->» Вони вказують на те, що у вас є символічне посилання.)
lrwxrwxrwx 1 root    root    36    Nov 27    2020    link_to_new_rpmfile.rpm -> /ddr/var/ext/link_to_new_rpmfile.rpm

3) Якщо ви знайшли підозріле посилання, перевірте, чи існує оригінальний файл.
#se ls -al /ddr/var/ext/link_to_new_rpmfile.rpm
ls: cannot access /ddr/var/ext/link_to_new_rpmfile.rpm

  4) Якщо ви отримуєте помилку про те, що файлу не існує, це підтверджує, що у вас є непрацююче символічне посилання. Його потрібно виправити, або видалити посилання.

5) Щоб виправити непрацююче посилання, відкрийте кейс зі службою підтримки Dell. Надайте вже зібрані докази та згадайте цю статтю в КБ.

受影響的產品

Data Domain
文章屬性
文章編號: 000214782
文章類型: Solution
上次修改時間: 02 10月 2023
版本:  3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。