Data Domain: NFS-koppeling: ls resulteert in fout: leesmap '.': Verouderde bestandsinge in totaal 0

摘要: NFS-koppeling bewerken: ls resulteert in de fout: het lezen van de directory '.': Verouderde bestandsinge in totaal 0 Eén oorzaak van deze fout is een verbroken symbolische koppeling met de directory. ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Clients kunnen worden gekoppeld aan NFS-export (bijvoorbeeld: /ddvar

De opdracht uitvoeren: "ls" resulteert in het bericht:
Verouderde bestandsingang

Clients kunnen cd-to-directory's onder /ddvar/ like releases of log en ls retourneert vervolgens resultaten.  
    "cd releases" of "cd log" en vervolgens "ls" slaagt.

原因

Een mogelijke oorzaak van dit gedrag is een verbroken symbolische koppeling.

解析度

Met de onderstaande stappen kunt u controleren of dit gedrag te wijten is aan een verbroken symbolische koppeling binnen de NFS-export (voorbeeld: /ddvar)

1) Ga naar de SE-modus en voer ls uit naar het exportpad. Voorbeeld:
ddvar #se ls -al /ddr/var/

OPMERKING:  ddvar is een speciaal pad. /ddvar wordt intern vertaald naar /ddr/var en moet worden gebruikt als /ddr/var bij het gebruik van interne opdrachten.
2) Zoek symbolische koppelingen:  (Noteer hieronder de 'l' op het meest linkse teken en ook de '->'. Deze geven aan dat u een symbolische koppeling hebt.)
lrwxrwxrwx 1 root    root    36    Nov 27    2020    link_to_new_rpmfile.rpm -> /ddr/var/ext/link_to_new_rpmfile.rpm

3) Als u een verdachte koppeling vindt, controleer dan of het oorspronkelijke bestand bestaat.
#se ls -al /ddr/var/ext/link_to_new_rpmfile.rpm
ls: cannot access /ddr/var/ext/link_to_new_rpmfile.rpm

  4) Als u een foutmelding krijgt dat het bestand niet bestaat, bevestigt dit dat u een gebroken symbolische koppeling hebt. Deze moet worden gecorrigeerd of de koppeling moet worden verwijderd.

5) Om een verbroken koppeling te corrigeren, opent u een case bij Dell Support. Verstrek het reeds verzamelde bewijs en vermeld dit KB-artikel.

受影響的產品

Data Domain
文章屬性
文章編號: 000214782
文章類型: Solution
上次修改時間: 02 10月 2023
版本:  3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。