Secure Connect Gateway - Het wijzigen van HTTP-proxyreferenties is niet effectief op gateways die zijn geüpgraded van SRS 3.52
摘要: In dit artikel wordt uitgelegd waarom het wijzigen van HTTP-proxyreferenties niet effectief is op gateways die zijn geüpgraded van SRS 3.52.
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
Een poging om de proxyreferenties te wijzigen na de migratie van SRS 3.52 naar SCG 5.20 (het enige migratiepad dat wordt ondersteund), leidt tot verlies van connectiviteit tussen de gateway en Dell.
原因
Het probleem doet zich alleen voor in het geval dat de proxyreferenties worden bijgewerkt na een migratie van SRS 3.x naar SCG 5.20. De Mosquitto.service bleek het wachtwoord te gebruiken dat was geconfigureerd in het mosquito.conf-bestand in plaats van de inloggegevens die waren opgeslagen in de LockBox. Er werd waargenomen dat de bijgewerkte inloggegevens worden opgeslagen in de Lockbox, maar mosquitto.conf wordt niet bijgewerkt. Omdat het wachtwoord voorrang heeft op het bestand mosquito.conf, werden de oude referenties gebruikt.
解析度
Upgrade de SCG-gateway van 5.20 naar een latere versie, waardoor de oude referenties van mosquitto.conf worden verwijderd.
Als de gateway op v5.20 moet blijven, voert u ook de volgende stappen uit:
Als de gateway op v5.20 moet blijven, voert u ook de volgende stappen uit:
- Pas nieuwe referenties van de SCG WebUI opnieuw toe, terwijl deze is verbonden.
- Ga met SSH naar de SCG-VE en log in als root.
- Voer de SRS-container in met behulp van
docker exec -it esrsde-app bash
- Reageer op het wachtwoord van mosquitto.conf met behulp van de onderstaande opdracht
-
sed -i 's/proxy_password/#proxy_password/g' /etc/mosquitto/conf.d/mosquitto.conf
- Start de Mosquitto-service opnieuw:
wd stop esrsmosquitto wd start esrsmosquitto
- Afmelden bij de container en SSH-sessie:
exit exit
- Zodra de bovenstaande stappen zijn toegepast, worden de referenties uit de Lockbox gehaald.
產品
Secure Connect Gateway, Secure Connect Gateway, Secure Connect Gateway - Virtual Edition文章屬性
文章編號: 000227392
文章類型: Solution
上次修改時間: 02 8月 2024
版本: 1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。