hoosier.daddy
1 Copper

Intel SSD on Latitude E6410?

Jump to solution

I tried to add a 160GB Intel SSD to a new E6410 and the bios does not recognize it, no matter where the SATA setting is in the bios... AHCI, ATA, RAID, etc.

No primary device in bios.

I used acronis to move my data to the drive so I know it works.

Any ideas?

0 Kudos
4 Solutions

Accepted Solutions

Re: Intel SSD on Latitude E6410?

Jump to solution

I had the same problem with a Latitude E6510 (with latest bios).  I put an Intel SSD in it and I could not get it recognized in the Windows 7 installation CD, nor Knoppix.  

It turned out I didn't have it physically connected properly.  The Intel SSD is much thinner than the SATA disk I replaced.  If you simply slide it into the chassis slot, it is possible that it the data connectors will not touch properly, but instead overlap.  The first indication that something wasn't right was when I went to screw in the 4 screws that secure the hard drive in the chassis, and the 2 screws on the data connector side were not long enough to attach (this is because the hard drive was cocked down at an angle, pushing the screw holes further away than they should have been).  I just left them out and booted up the computer, and that is when I was experiencing the problem mentioned above.

To fix the problem, I took a good look inside the hard drive slot to figure out where the data connectors should be making contact.  I flipped the laptop over so that gravity would assist in lining them up as I more carefully inserted the SSD.  This time, it seemed to slide in more deeply, and all 4 screws were secured this time.

 

View solution in original post

Jim_Ryan_DNI
1 Copper

Re: Intel SSD on Latitude E6410?

Jump to solution

I have same problem with Crucial SSD, contacted Dell Support, no help from Dell, the guy didn't even suggest to update BIOS, found out that my BIOS was very old, updated BIOS, still same problem, then found that SSD was not properly sidding in, as they are slimmer than regualar HDD. Fixed by properly inserting it in. Now it works. No BIOS setup is needed.

View solution in original post

OERN
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Thanks. Was wondering why it went in so lightly.
Confirming exactly this behavioral on Dell Latitulde E6320 with Kingston SSD.

View solution in original post

Ffoley
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Fabulous advice...min new drive was thinner than the original...careful reseating and gravity fixed the issue...now my laptol recognizes the new drive...thanks !!!

View solution in original post

19 Replies

Re: Intel SSD on Latitude E6410?

Jump to solution

Look to see if Dell has provided a BIOS update for your motherboard. If so then this may enable your ability to use the SSD.

Failing that you can try, just to see if it works, to boot to the Vista/Win7 Repair environment or XP recovery environment (depending on OS) with your install disc then run FIXMBR C: (or whatever your drive letter is) from there.
Be warned: with ANY low-level tool you run the risk of destroying all data on that drive (though it is very very very small of a chance; it may be more accurate to say it's a non-zero chance than to say you're 99.99999999999999999999999999% not likely to lose data).

If you leave the original drive disconnected form the machine as you do this then you should be ok & be able to re-clone with Acronis later.

___________________________________________
Inspiron 11-3180 (late 2018) - A6-9220e, 4GB, 32GB eMMC
Inspiron Micro Desktop (mid 2015) - Celeron, 4GB, 32GB eMMC

Feel free to call me Greggers
jim_survak on Alienware Arena
Other: iPhone XR, iPad Air, Mac mini, Hisses Chromebook (ARM-powered)
Retired and Donated to charity: Inspiron 530, Inspiron Mini 10, Inspiron M5030 (donated to mom, she's a charity case :P), XPS 720 Red & Silver, Venue 8 Pro - Red edition, Inspiron 11-3162
0 Kudos

Re: Intel SSD on Latitude E6410?

Jump to solution

I had the same problem with a Latitude E6510 (with latest bios).  I put an Intel SSD in it and I could not get it recognized in the Windows 7 installation CD, nor Knoppix.  

It turned out I didn't have it physically connected properly.  The Intel SSD is much thinner than the SATA disk I replaced.  If you simply slide it into the chassis slot, it is possible that it the data connectors will not touch properly, but instead overlap.  The first indication that something wasn't right was when I went to screw in the 4 screws that secure the hard drive in the chassis, and the 2 screws on the data connector side were not long enough to attach (this is because the hard drive was cocked down at an angle, pushing the screw holes further away than they should have been).  I just left them out and booted up the computer, and that is when I was experiencing the problem mentioned above.

To fix the problem, I took a good look inside the hard drive slot to figure out where the data connectors should be making contact.  I flipped the laptop over so that gravity would assist in lining them up as I more carefully inserted the SSD.  This time, it seemed to slide in more deeply, and all 4 screws were secured this time.

 

View solution in original post

maraleanton
1 Copper

Re: Intel SSD on Latitude E6410?

Jump to solution

I have the same problem.

The Dell Contact center instruct me to download and install the latest bios, so I did it, now I have Version A11 and my DELL LATITUDE E6410 still not recognize my SSD, SAMSUNG 128GB.

The SSD works with any problem on my other LENOVO T400.

I am waitting for any that coul solve my problem

Marcelo

0 Kudos
Jim_Ryan_DNI
1 Copper

Re: Intel SSD on Latitude E6410?

Jump to solution

I have same problem with Crucial SSD, contacted Dell Support, no help from Dell, the guy didn't even suggest to update BIOS, found out that my BIOS was very old, updated BIOS, still same problem, then found that SSD was not properly sidding in, as they are slimmer than regualar HDD. Fixed by properly inserting it in. Now it works. No BIOS setup is needed.

View solution in original post

Newt81
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Same problem here. I am using Dell Latitude E6410 and bought a Segate 240 GB Solid State Drive and trying to use it.

Tags (1)
0 Kudos
maraleanton
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Finally, I bougth a new Samsung SSD 840 series, 250Go, SATA III, 2.5pulg and it works OK.
From DELL nobody answer my question. Very poor customer care support

0 Kudos
Newt81
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Make and model of the SDD I tried is below, so Dell supports only Samsung SDD? I have no luck with Dell customer support either.

Seagate 600 Series ST240HM000 2.5" 240GB SATA III MLC Internal Solid State Drive (SSD)

0 Kudos
Newt81
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Good to know that it worked for you. What is your BIOS version btw? Mine is A15 also, what is your BIOS settings used (ATA/ SHCI / RAID) ?

0 Kudos
Newt81
1 Copper

RE: Intel SSD on Latitude E6410?

Jump to solution

Folks! emoticon.BigSmile.title

Finally, my SDD started working on Dell Latitude E6410. I formatted my new SSD (NTFS) and connected it. It picked it up and started installing.

I did not change any settings (RAID On) should be best.

-NewT

0 Kudos